package/tftpd: bump to latest git commit
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 18 Jul 2021 21:55:16 +0000 (23:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Jul 2021 10:17:55 +0000 (12:17 +0200)
- Update indention in hash file (two spaces)
- This will fix a static build failure with gcc-10 thanks to
  https://git.kernel.org/pub/scm/network/tftp/tftp-hpa.git/commit/?id=18ac1e26f756dd47fef33f5f706b0ec8fa696216

Fixes:
 - http://autobuild.buildroot.org/results/913e8b75422c8beba60df5ea2e2c9e431364566e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/tftpd/tftpd.hash
package/tftpd/tftpd.mk

index c876b2edc24e8f6a2f169a6ee8c7f177dfcdd02d..3cccb0f20eafd44b85aa7dbe6bbcd3acc6ffc79b 100644 (file)
@@ -1,5 +1,5 @@
-# From https://www.kernel.org/pub/software/network/tftp/tftp-hpa/sha256sums.asc
-sha256 afee361df96a2f88344e191f6a25480fd714e1d28d176c3f10cc43fa206b718b        tftp-hpa-5.2.tar.xz
+# Locally calculated
+sha256  c86520c30dab0b6bcbae021ab26d2ac63227696596d37a9b02aa3e56ec5c2e77  tftpd-b2b34cecc8cbc18ff6f1fc00bda6ae6e9011e6c7-br1.tar.gz
 
 # Hash for license file
-sha256 5efef82650b8ece733e37790fc70f05e426c9e1ef9640d4ebcb04867bd3f5e28        tftpd/tftpd.c
+sha256  67754ebd8f265571d3226ac97e521b1bd6fd8a61363ecd4ab7806a6f90efab92  tftpd/tftpd.c
index 494e963d64532d1b29e7dfc6f63e03e093ed4637..ffd52ce0d0d3e05f3c1f1a1c86994cdc17ce38eb 100644 (file)
@@ -4,14 +4,15 @@
 #
 ################################################################################
 
-TFTPD_VERSION = 5.2
-TFTPD_SOURCE = tftp-hpa-$(TFTPD_VERSION).tar.xz
-TFTPD_SITE = $(BR2_KERNEL_MIRROR)/software/network/tftp/tftp-hpa
+TFTPD_VERSION = b2b34cecc8cbc18ff6f1fc00bda6ae6e9011e6c7
+TFTPD_SITE = git://git.kernel.org/pub/scm/network/tftp/tftp-hpa.git
 TFTPD_CONF_OPTS = --without-tcpwrappers
 TFTPD_LICENSE = BSD-4-Clause
 TFTPD_LICENSE_FILES = tftpd/tftpd.c
 TFTPD_CPE_ID_VENDOR = tftpd-hpa_project
 TFTPD_CPE_ID_PRODUCT = tftpd-hpa
+# From git
+TFTPD_AUTORECONF = YES
 
 define TFTPD_INSTALL_TARGET_CMDS
        $(INSTALL) -D $(@D)/tftp/tftp $(TARGET_DIR)/usr/bin/tftp