python-netifaces: convert to the Python package infrastructure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Dec 2013 20:26:54 +0000 (21:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:41:22 +0000 (13:41 +0100)
Also, remove the "select BR2_PACKAGE_PYTHON_SETUPTOOLS", since
setuptools is a host dependency (needed to built the package), not a
target dependency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python-netifaces/Config.in
package/python-netifaces/python-netifaces.mk

index b9d66d8b644849406af7e3c07541aeab20f5b8cb..29f9fc33a7a26a695ed930d8f21aad64b1fce627 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_PYTHON_NETIFACES
        bool "python-netifaces"
        depends on BR2_PACKAGE_PYTHON
-       select BR2_PACKAGE_PYTHON_SETUPTOOLS
        help
          Portable access to network interfaces from Python.
 
index 1570fd1c4881d43a044182be8605e41ea880241c..faa39bd87cd8b72629f9db40684f307d44e4d714 100644 (file)
@@ -7,21 +7,6 @@
 PYTHON_NETIFACES_VERSION = 0.7
 PYTHON_NETIFACES_SOURCE  = netifaces-$(PYTHON_NETIFACES_VERSION).tar.gz
 PYTHON_NETIFACES_SITE    = http://alastairs-place.net/projects/netifaces
+PYTHON_NETIFACES_SETUP_TYPE = setuptools
 
-PYTHON_NETIFACES_DEPENDENCIES = python host-python-setuptools host-python-distutilscross
-
-define PYTHON_NETIFACES_BUILD_CMDS
-       (cd $(@D); \
-               PYTHONXCPREFIX="$(STAGING_DIR)/usr/" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
-       $(HOST_DIR)/usr/bin/python setup.py build -x)
-endef
-
-define PYTHON_NETIFACES_INSTALL_TARGET_CMDS
-       (cd $(@D); \
-       PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
-       $(HOST_DIR)/usr/bin/python setup.py install \
-       --single-version-externally-managed --root=/ --prefix=$(TARGET_DIR)/usr)
-endef
-
-$(eval $(generic-package))
+$(eval $(python-package))