wget: bump to 1.12 and migrate to Makefile.autotools.in
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 18 Feb 2010 17:51:51 +0000 (14:51 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Mar 2010 13:07:30 +0000 (14:07 +0100)
Closes #1111.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/wget/Config.in
package/wget/wget.mk

diff --git a/CHANGES b/CHANGES
index 3f5f941dd2b5b20e359c7abe1ef2fd6475ff6d66..efc11367e902718d436c6ca0253eb8818c66ca5a 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -6,10 +6,11 @@
        X.org updated to 7.5.
 
        Updated/fixed packages: busybox, dosfstools, e2fsprogs,
-       libglib2, libpng, mtd-utils, pppd, setserial, squashfs
+       libglib2, libpng, mtd-utils, pppd, setserial, squashfs, wget
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #1111: Bump wget to 1.12 and migrate to Makefile.autotools.in
        #1273: BR2_INET_IPV6 does not enable IPv6 in pppd
        #1345: Bump pppd to 2.4.5 and convert to Makefile.autotools.in
 
index b53cc9513966453aa7d46d4e2294d288c32b9e2b..3877a3af5b5547a3d9f57c405c7fadbd211255e0 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_WGET
        bool "wget"
        help
-         Network utility to retrieve files from http/ftp/etc...
+         Network utility to retrieve files from http, https and ftp.
 
-         http://wget.sunsite.dk/
+         http://www.gnu.org/software/wget/
index 06e54c74559db32ddc670fcbab88f3dcb2d00bd8..cb0c60aa3676612d9e917522bed5aa6aca68bd9a 100644 (file)
@@ -3,58 +3,14 @@
 # wget
 #
 #############################################################
-WGET_VERSION:=1.10.2
-WGET_SOURCE:=wget-$(WGET_VERSION).tar.gz
-WGET_SITE:=$(BR2_GNU_MIRROR)/wget
-WGET_DIR:=$(BUILD_DIR)/wget-$(WGET_VERSION)
-WGET_CAT:=$(ZCAT)
-WGET_BINARY:=src/wget
-WGET_TARGET_BINARY:=bin/wget
 
-$(DL_DIR)/$(WGET_SOURCE):
-       $(call DOWNLOAD,$(WGET_SITE),$(WGET_SOURCE))
+WGET_VERSION = 1.12
+WGET_SITE = $(BR2_GNU_MIRROR)/wget
+WGET_CONF_OPT = $(DISABLE_IPV6)
 
-wget-source: $(DL_DIR)/$(WGET_SOURCE)
-
-$(WGET_DIR)/.unpacked: $(DL_DIR)/$(WGET_SOURCE)
-       $(WGET_CAT) $(DL_DIR)/$(WGET_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(CONFIG_UPDATE) $(WGET_DIR)
-       touch $@
-
-$(WGET_DIR)/.configured: $(WGET_DIR)/.unpacked
-       (cd $(WGET_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               $(TARGET_CONFIGURE_ARGS) \
-               ./configure $(QUIET) \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/ \
-               --disable-ipv6 \
-               $(DISABLE_NLS) \
-               --without-ssl \
-       )
-       touch $@
-
-$(WGET_DIR)/$(WGET_BINARY): $(WGET_DIR)/.configured
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(WGET_DIR)
-
-$(TARGET_DIR)/$(WGET_TARGET_BINARY): $(WGET_DIR)/$(WGET_BINARY)
-       install -D $(WGET_DIR)/$(WGET_BINARY) $(TARGET_DIR)/$(WGET_TARGET_BINARY)
-
-wget: $(TARGET_DIR)/$(WGET_TARGET_BINARY)
-
-wget-clean:
-       rm -f $(TARGET_DIR)/$(WGET_TARGET_BINARY)
-       -$(MAKE) -C $(WGET_DIR) clean
-
-wget-dirclean:
-       rm -rf $(WGET_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_WGET),y)
-TARGETS+=wget
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+       WGET_CONF_OPT += --with-ssl --with-libssl-prefix=$(STAGING_DIR)
+       WGET_DEPENDENCIES += openssl
 endif
+
+$(eval $(call AUTOTARGETS,package,wget))