package/gmrender-resurrect: bump to version 0.0.8
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 26 Dec 2019 09:00:54 +0000 (10:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 26 Dec 2019 12:41:36 +0000 (13:41 +0100)
libupnp18 is supported since
https://github.com/hzeller/gmrender-resurrect/commit/cc96edeb70fa2938a4d963524261142132ece540

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gmrender-resurrect/Config.in
package/gmrender-resurrect/gmrender-resurrect.hash
package/gmrender-resurrect/gmrender-resurrect.mk

index db655ad7f4311cc4fcc0a5d4fa7c413b200f8c3a..e7424e3b228d919407b1d63ebe1d203f503900d4 100644 (file)
@@ -5,7 +5,7 @@ config BR2_PACKAGE_GMRENDER_RESURRECT
        depends on BR2_USE_MMU # gstreamer1
        select BR2_PACKAGE_GSTREAMER1
        select BR2_PACKAGE_GST1_PLUGINS_BASE # run-time only
-       select BR2_PACKAGE_LIBUPNP
+       select BR2_PACKAGE_LIBUPNP18 if !BR2_PACKAGE_LIBUPNP
        help
          UPnP (DLNA) media renderer based on gstreamer
 
index 85d6ad4629104bb2afc77a73da7ae5edbab5fdb5..dc474be612303707b0cb4cca2fd579b99c2ab626 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 79dba7cbd275098026a16829597b7013ab71a9cca4c9762af6f210637099c39a  gmrender-resurrect-a7b0b1b9ca482d2d34ac62c2f2dc0cf0dfbb702b.tar.gz
+sha256 1f0cef76e4543879c9cd31cad73d6c4f778b965884c586405efcf63f2bdbb06f  gmrender-resurrect-0.0.8.tar.gz
 sha256 c38aee9e3c8c4d5d594ff548a1be05453023016d6286931f6512db215ec1fd42  COPYING
index 432ed8424e002ddc9c04b685b143baf810f8a49c..e25be394934b1e28db2fd2959a1eb3faa63d595f 100644 (file)
@@ -4,13 +4,15 @@
 #
 ################################################################################
 
-GMRENDER_RESURRECT_VERSION = a7b0b1b9ca482d2d34ac62c2f2dc0cf0dfbb702b
-GMRENDER_RESURRECT_SITE = $(call github,hzeller,gmrender-resurrect,$(GMRENDER_RESURRECT_VERSION))
+GMRENDER_RESURRECT_VERSION = 0.0.8
+GMRENDER_RESURRECT_SITE = $(call github,hzeller,gmrender-resurrect,v$(GMRENDER_RESURRECT_VERSION))
 # Original distribution does not have default configure,
 # so we need to autoreconf:
 GMRENDER_RESURRECT_AUTORECONF = YES
 GMRENDER_RESURRECT_LICENSE = GPL-2.0+
 GMRENDER_RESURRECT_LICENSE_FILES = COPYING
-GMRENDER_RESURRECT_DEPENDENCIES = gstreamer1 libupnp
+GMRENDER_RESURRECT_DEPENDENCIES = \
+       gstreamer1 \
+       $(if $(BR2_PACKAGE_LIBUPNP),libupnp,libupnp18)
 
 $(eval $(autotools-package))