external toolchain: check cross-compiler existence
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 06:53:55 +0000 (08:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 06:53:55 +0000 (08:53 +0200)
As a minimal test to the external toolchain, check that $(TARGET_CC)
is actually an existing executable file. That way, if the user
misconfigures the toolchain path and/or prefix, a meaningful error
message will be shown.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/external-toolchain/ext-tool.mk

index c9692a1abbe8d86914aa419faf86991612030be6..d441a92524f96763d2707525749c9dda0e3a5def 100644 (file)
@@ -181,6 +181,15 @@ check_arm_abi = \
                exit 1 ; \
        fi ; \
 
+#
+# Check that the cross-compiler given in the configuration exists
+#
+check_cross_compiler_exists = \
+       if ! test -x $(TARGET_CC) ; then \
+               echo "Cannot find cross-compiler $(TARGET_CC)" ; \
+               exit 1 ; \
+       fi ; \
+
 uclibc: dependencies $(STAMP_DIR)/ext-toolchain-installed
 
 EXTERNAL_LIBS=libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libpthread.so libresolv.so librt.so libutil.so
@@ -198,6 +207,7 @@ SYSROOT_DIR=$(shell LANG=C $(TARGET_CC) -v 2>&1 | grep ^Configured | tr " " "\n"
 
 $(STAMP_DIR)/ext-toolchain-installed:
        @echo "Checking external toolchain settings"
+       $(Q)$(call check_cross_compiler_exists)
 ifeq ($(strip $(SYSROOT_DIR)),)
        @echo "External toolchain doesn't support --sysroot. Cannot use."
        exit 1