libpam-radius-auth: new package
authorGiovanni Zantedeschi <giovanni.zantedeschi@datacom.ind.br>
Wed, 19 Aug 2015 20:46:48 +0000 (17:46 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Aug 2015 08:59:55 +0000 (10:59 +0200)
[Thomas:
  - make libpam-radius-auth depend on linux-pam (since it's a
    linux-pam plugin, it needs some header files from linux-pam) by
    adding a "if BR2_PACKAGE_LINUX_PAM...endif" block in
    package/Config.in. This way, we will be grouping all the Linux PAM
    plugins together.
  - Fix the indententation in the Config.in file.
  - Use a better Config.in help text, copy/pasted from the website.
  - Use a tarball instead of github. This allows to remove
    AUTORECONF=YES.
  - Add linux-pam as a dependency.
  - Use $(TARGET_CONFIGURE_OPTS) instead of passing just CC/LD, but
    pass it in the environment rather than as options so that the
    CFLAGS/LDFLAGS added by the package Makefile are still taken into
    account.
  - Use mkdir -p + cp -dpfr instead of $(INSTALL) -D since we are
    copying multiple files.
  - Add a hash file.]

Signed-off-by: Giovanni Zantedeschi <giovanni.zantedeschi@datacom.ind.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libpam-radius-auth/Config.in [new file with mode: 0644]
package/libpam-radius-auth/libpam-radius-auth.hash [new file with mode: 0644]
package/libpam-radius-auth/libpam-radius-auth.mk [new file with mode: 0644]

index 729df7a38a218d5c9cfe7df8c87013ba01266150..b92dc05534490c7dffc5fa7daf4ee24931f88ee9 100644 (file)
@@ -1093,6 +1093,10 @@ menu "Other"
        source "package/libuv/Config.in"
        source "package/lightning/Config.in"
        source "package/linux-pam/Config.in"
+if BR2_PACKAGE_LINUX_PAM
+comment "linux-pam plugins"
+       source "package/libpam-radius-auth/Config.in"
+endif
        source "package/lttng-libust/Config.in"
        source "package/mpc/Config.in"
        source "package/mpdecimal/Config.in"
diff --git a/package/libpam-radius-auth/Config.in b/package/libpam-radius-auth/Config.in
new file mode 100644 (file)
index 0000000..a0dec14
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBPAM_RADIUS_AUTH
+       bool "libpam-radius-auth"
+       help
+         This is the PAM to RADIUS authentication module. It allows
+         any PAM-capable machine to become a RADIUS client for
+         authentication and accounting requests. You will need a
+         RADIUS server to perform the actual authentication.
+
+         http://freeradius.org/pam_radius_auth/
diff --git a/package/libpam-radius-auth/libpam-radius-auth.hash b/package/libpam-radius-auth/libpam-radius-auth.hash
new file mode 100644 (file)
index 0000000..ffd7404
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated after checking PGP signature
+sha256   742d79fc39824726c098e746bd3dc3484f983f5ee082c621c1e848b2c3725305      pam_radius-1.4.0.tar.gz
diff --git a/package/libpam-radius-auth/libpam-radius-auth.mk b/package/libpam-radius-auth/libpam-radius-auth.mk
new file mode 100644 (file)
index 0000000..42acffd
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# libpam-radius-auth
+#
+################################################################################
+
+LIBPAM_RADIUS_AUTH_VERSION = 1.4.0
+LIBPAM_RADIUS_AUTH_SITE = ftp://ftp.freeradius.org/pub/radius/
+LIBPAM_RADIUS_AUTH_SOURCE = pam_radius-$(LIBPAM_RADIUS_AUTH_VERSION).tar.gz
+LIBPAM_RADIUS_AUTH_DEPENDENCIES = linux-pam
+LIBPAM_RADIUS_AUTH_INSTALL_STAGING = YES
+LIBPAM_RADIUS_AUTH_LICENSE = GPLv2+
+LIBPAM_RADIUS_AUTH_LICENSE_FILES = LICENSE
+# While autoconf is used for configuration, the Makefile is
+# hand-written, so we need to pass CC, LD, CFLAGS at build time.
+LIBPAM_RADIUS_AUTH_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
+
+define LIBPAM_RADIUS_AUTH_INSTALL_STAGING_CMDS
+       mkdir -p $(STAGING_DIR)/lib/security/
+       cp -dpfr $(@D)/pam_radius_auth.so* $(STAGING_DIR)/lib/security/
+endef
+
+define LIBPAM_RADIUS_AUTH_INSTALL_TARGET_CMDS
+       mkdir -p $(TARGET_DIR)/lib/security/
+       cp -dpfr $(@D)/pam_radius_auth.so* $(TARGET_DIR)/lib/security/
+endef
+
+$(eval $(autotools-package))