package/gst1-libav: fix build on mips64el
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 29 Mar 2019 15:30:39 +0000 (16:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 29 Mar 2019 16:06:08 +0000 (17:06 +0100)
Apply the same behavior for CPU in gst1-libav than in ffmpeg:
 - use generic cpu for all mips architectures
 - use GCC_TARGET_{ARCH,CPU} instead of BR2_TARGET_{ARCH,CPU}

Fixes:
 - http://autobuild.buildroot.org/results/776028a43bd180b4895efc74321e3aee56cbcb47

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-libav/gst1-libav.mk

index 254ab719ae073d3f97e0bc94335ee07b36b72a58..73e47a0639830445a2879bd6816f4136b3a1733c 100644 (file)
@@ -35,10 +35,14 @@ GST1_LIBAV_CONF_EXTRA_OPTS += --disable-bzlib
 endif
 
 # Generic CPU setup for bundled ffmpeg
-ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
-GST1_LIBAV_CONF_EXTRA_OPTS += --cpu=$(BR2_GCC_TARGET_CPU)
-else ifneq ($(call qstrip,$(BR2_GCC_TARGET_ARCH)),)
-GST1_LIBAV_CONF_EXTRA_OPTS += --cpu=$(BR2_GCC_TARGET_ARCH)
+# Default to --cpu=generic for MIPS architecture, in order to avoid a
+# build failure on mips64r6.
+ifeq ($(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el),y)
+GST1_LIBAV_CONF_EXTRA_OPTS += --cpu=generic
+else ifneq ($(GCC_TARGET_CPU),)
+GST1_LIBAV_CONF_EXTRA_OPTS += --cpu=$(GCC_TARGET_CPU)
+else ifneq ($(GCC_TARGET_ARCH),)
+GST1_LIBAV_CONF_EXTRA_OPTS += --cpu=$(GCC_TARGET_ARCH)
 endif
 
 ifeq ($(BR2_X86_CPU_HAS_MMX),y)