ntp: explicitly enable openssl-random when crypto is enabled
authorAdam Duskett <aduskett@gmail.com>
Wed, 8 Nov 2017 13:18:39 +0000 (08:18 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Feb 2018 15:20:38 +0000 (16:20 +0100)
If OpenSSL is selected, --enable-openssl-random should be explicitly
enabled for consistency with the disable case.

[Peter: tweak commit text]
Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ntp/ntp.mk

index 74cf5469889553ed79fb49f50ae03cadd01182a3..cc363269c369240adb0597ac6cdf28f4f16de966 100644 (file)
@@ -24,7 +24,7 @@ NTP_CONF_OPTS = \
 NTP_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
-NTP_CONF_OPTS += --with-crypto
+NTP_CONF_OPTS += --with-crypto --enable-openssl-random
 NTP_DEPENDENCIES += openssl
 else
 NTP_CONF_OPTS += --without-crypto --disable-openssl-random