package/bird: add rpki support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 21 Jul 2021 06:45:13 +0000 (08:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 21 Jul 2021 07:25:48 +0000 (09:25 +0200)
rpki support optionally depends on libssh

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bird/Config.in
package/bird/bird.mk

index e78dfdf90f52d7361d96e0125be1f5283ac7db17..866fc65617fcbe25727948dd048dec9ee3542824 100644 (file)
@@ -73,6 +73,11 @@ config BR2_PACKAGE_BIRD_RIP
        help
          Enable RIP protocol.
 
+config BR2_PACKAGE_BIRD_RPKI
+       bool "rpki"
+       help
+         Enable RPKI protocol.
+
 config BR2_PACKAGE_BIRD_STATIC
        bool "static"
        help
index 4d4dfe1dcaed83cc510c3b22c99d73d5faafe0c7..4d6159b075a6b1fc2c06feca5783e3425dc19ac2 100644 (file)
@@ -19,6 +19,13 @@ else
 BIRD_CONF_OPTS += --disable-client
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSSH),y)
+BIRD_CONF_OPTS += --enable-libssh
+BIRD_DEPENDENCIES += libssh
+else
+BIRD_CONF_OPTS += --disable-libssh
+endif
+
 BIRD_PROTOCOLS = \
        $(if $(BR2_PACKAGE_BIRD_BFD),bfd) \
        $(if $(BR2_PACKAGE_BIRD_BABEL),babel) \
@@ -29,6 +36,7 @@ BIRD_PROTOCOLS = \
        $(if $(BR2_PACKAGE_BIRD_PIPE),pipe) \
        $(if $(BR2_PACKAGE_BIRD_RADV),radv) \
        $(if $(BR2_PACKAGE_BIRD_RIP),rip) \
+       $(if $(BR2_PACKAGE_BIRD_RPKI),rpki) \
        $(if $(BR2_PACKAGE_BIRD_STATIC),static)
 
 BIRD_CONF_OPTS += --with-protocols=$(subst $(space),$(comma),$(strip $(BIRD_PROTOCOLS)))