package/hostapd: add Config.in option for WPA3 support
authorSergey Matyukevich <geomatsi@gmail.com>
Mon, 9 Sep 2019 20:20:33 +0000 (23:20 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 21 Sep 2019 15:55:41 +0000 (17:55 +0200)
New hostapd v2.9 supports WPA3 features such as OWE, SAE, DPP.
Those features are disabled by default in defconfig, so no
dependency from openssl is requried unless WPA3 support
is enabled.

This patch adds Config.in option for WPA3 support in hostapd.
When this option is selected, libopenssl is also selected and
WPA3 features including OWE, SAE, DPP are enabled in hostapd
.config file. When this option is deselected, then WPA3
options are disabled.

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/hostapd/Config.in
package/hostapd/hostapd.mk

index 8a7abbb901a25110b22323a281c4add822b84bc0..54d2086c0973500a0436e2361cc242390b0c356b 100644 (file)
@@ -74,6 +74,13 @@ config BR2_PACKAGE_HOSTAPD_WPS
        help
          Enable support for Wi-Fi Protected Setup.
 
+config BR2_PACKAGE_HOSTAPD_WPA3
+       bool "Enable WPA3 support"
+       select BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_OPENSSL_FORCE_LIBOPENSSL
+       help
+         Enable WPA3 support including OWE, SAE, DPP
+
 config BR2_PACKAGE_HOSTAPD_VLAN
        bool "Enable VLAN support"
        default y
index fb6ac8fb2e1aa4cc64d4dbb76b956d01c7ecd0b0..4a493cb9b2600d819f72ba18671707f89865cb38 100644 (file)
@@ -79,6 +79,17 @@ ifeq ($(BR2_PACKAGE_HOSTAPD_WPS),y)
 HOSTAPD_CONFIG_ENABLE += CONFIG_WPS
 endif
 
+ifeq ($(BR2_PACKAGE_HOSTAPD_WPA3),y)
+HOSTAPD_CONFIG_SET += \
+       CONFIG_DPP \
+       CONFIG_SAE
+HOSTAPD_CONFIG_ENABLE += \
+       CONFIG_OWE
+else
+HOSTAPD_CONFIG_DISABLE += \
+       CONFIG_OWE
+endif
+
 ifeq ($(BR2_PACKAGE_HOSTAPD_VLAN),)
 HOSTAPD_CONFIG_ENABLE += CONFIG_NO_VLAN
 endif