libssh2: fix build with libgcrypt and mbedtls enabled
authorBaruch Siach <baruch@tkos.co.il>
Fri, 28 Jul 2017 04:28:13 +0000 (07:28 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Jul 2017 13:52:19 +0000 (15:52 +0200)
The --without-libgcrypt configure parameter is not enough to disable the
libgcrypt back-end. This breaks the build when mbedtls (default backend) is
enabled, and libgcrypt builds before libssh2. Seed ac_cv_libgcrypt to really
disable libgcrypt when it is not the selected crypto back-end.

Fixes:
http://autobuild.buildroot.net/results/b4e/b4e39890e003e9e590a5bf17c9300c653020d88c/
http://autobuild.buildroot.net/results/45a/45a9b3559ceea4e1399794f9612f717f7c57a4a3/
http://autobuild.buildroot.net/results/ae4/ae4afec62ca297df1cd02350601f1d62fc3cd1b7/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libssh2/libssh2.mk

index 338f5b458f11e49da8b75187f6cf2c9e8a2ca986..41279342750bc4406030bc02f0fc05c72bb3b8a6 100644 (file)
@@ -17,6 +17,7 @@ ifeq ($(BR2_PACKAGE_MBEDTLS),y)
 LIBSSH2_DEPENDENCIES += mbedtls
 LIBSSH2_CONF_OPTS += --with-mbedtls=$(STAGING_DIR)/usr \
        --without-openssl --without-libgcrypt
+LIBSSH2_CONF_ENV += ac_cv_libgcrypt=no
 else ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 LIBSSH2_DEPENDENCIES += libgcrypt
 LIBSSH2_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr \