package/dhcpcd: enhance syntax
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 26 Dec 2020 17:17:43 +0000 (18:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Dec 2020 17:28:12 +0000 (18:28 +0100)
Add all configure options through DHCP_CONFIG_OPTS and avoid splitting
lines when they are less than 80 characters

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dhcpcd/dhcpcd.mk

index 0dcd36f3695fa2a37ffd50dc82cf9ad0d8dca1f7..11d78e1847b53cc1022efe4b9aa53396144eefdd 100644 (file)
@@ -11,6 +11,10 @@ DHCPCD_DEPENDENCIES = host-pkgconf
 DHCPCD_LICENSE = BSD-2-Clause
 DHCPCD_LICENSE_FILES = LICENSE
 
+DHCPCD_CONFIG_OPTS = \
+       --libexecdir=/lib/dhcpcd \
+       --os=linux
+
 ifeq ($(BR2_STATIC_LIBS),y)
 DHCPCD_CONFIG_OPTS += --enable-static
 endif
@@ -20,16 +24,11 @@ DHCPCD_CONFIG_OPTS += --disable-fork --disable-privsep
 endif
 
 define DHCPCD_CONFIGURE_CMDS
-       (cd $(@D); \
-       $(TARGET_CONFIGURE_OPTS) ./configure \
-               --os=linux \
-               --libexecdir=/lib/dhcpcd \
-               $(DHCPCD_CONFIG_OPTS) )
+       (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure $(DHCPCD_CONFIG_OPTS))
 endef
 
 define DHCPCD_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) \
-               -C $(@D) all
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) all
 endef
 
 define DHCPCD_INSTALL_TARGET_CMDS