package/python-simplelogging: new package
authorJoris Offouga <offougajoris@gmail.com>
Mon, 16 Sep 2019 16:23:03 +0000 (18:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Sep 2019 21:18:10 +0000 (23:18 +0200)
Simplelogging is easier implementation of logging.

Signed-off-by: Joris Offouga <offougajoris@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-simplelogging/Config.in [new file with mode: 0644]
package/python-simplelogging/python-simplelogging.hash [new file with mode: 0644]
package/python-simplelogging/python-simplelogging.mk [new file with mode: 0644]

index b1f62edd5768016e6621e972f2b3e55396f2c694..1557608356cc93b284cf7e141bfedcab931a7cd5 100644 (file)
@@ -1228,6 +1228,7 @@ F:        package/supervisor/
 
 N:     Joris Offouga <offougajoris@gmail.com>
 F:     package/python-colorlog/
+F:     package/python-simplelogging/
 
 N:     Jörg Krause <joerg.krause@embedded.rocks>
 F:     board/lemaker/bananapro/
index e227f7c46f0be722eaa7dd56b3bd51efc9244e8b..1026dd7c16aa816ee523f4131631f1e7417c2bb0 100644 (file)
@@ -1070,6 +1070,7 @@ menu "External python modules"
        source "package/python-simpleaudio/Config.in"
        source "package/python-simplegeneric/Config.in"
        source "package/python-simplejson/Config.in"
+       source "package/python-simplelogging/Config.in"
        source "package/python-simplesqlite/Config.in"
        source "package/python-singledispatch/Config.in"
        source "package/python-sip/Config.in"
diff --git a/package/python-simplelogging/Config.in b/package/python-simplelogging/Config.in
new file mode 100644 (file)
index 0000000..db95efa
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_SIMPLELOGGING
+       bool "python-simplelogging"
+       select BR2_PACKAGE_PYTHON_COLORLOG # runtime
+       help
+         Logging made simple, no excuse for any debug print call.
+
+         https://github.com/vpoulailleau/simplelogging
diff --git a/package/python-simplelogging/python-simplelogging.hash b/package/python-simplelogging/python-simplelogging.hash
new file mode 100644 (file)
index 0000000..86698fe
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/simplelogging/json
+md5    e3f9da393098d8fd8ebd8349a00692f2  simplelogging-0.10.0.tar.gz
+sha256 c070e0d82b68eff6918076a0edbf0a48b2c9a263854bd35f48a12c6adbbe9d80  simplelogging-0.10.0.tar.gz
+# Locally computed sha256 checksums
+sha256 bd2a0fe3b3bab7092ffa7f58d46bb05d98f12f107b3a6be947c098f7c2ad1d1a  LICENSE
diff --git a/package/python-simplelogging/python-simplelogging.mk b/package/python-simplelogging/python-simplelogging.mk
new file mode 100644 (file)
index 0000000..28acc5c
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-simplelogging
+#
+################################################################################
+
+PYTHON_SIMPLELOGGING_VERSION = 0.10.0
+PYTHON_SIMPLELOGGING_SOURCE = simplelogging-$(PYTHON_SIMPLELOGGING_VERSION).tar.gz
+PYTHON_SIMPLELOGGING_SITE = https://files.pythonhosted.org/packages/17/85/3d2431f971e703916c7254e4560ed15451faedf2461eb484da9e1ebc5da6
+PYTHON_SIMPLELOGGING_SETUP_TYPE = setuptools
+PYTHON_SIMPLELOGGING_LICENSE = BSD-3-Clause
+PYTHON_SIMPLELOGGING_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))