package/libgcrypt: bump to version 1.9.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 21 Jan 2021 20:43:57 +0000 (21:43 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 21 Jan 2021 22:03:39 +0000 (23:03 +0100)
Drop first patch (already in version)

https://dev.gnupg.org/T4294

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libgcrypt/0001-build-Don-t-default-to-underscore-yes-for-cross-buil.patch [deleted file]
package/libgcrypt/0001-configure.ac-add-an-option-to-disable-tests.patch [new file with mode: 0644]
package/libgcrypt/0002-configure.ac-add-an-option-to-disable-tests.patch [deleted file]
package/libgcrypt/libgcrypt.hash
package/libgcrypt/libgcrypt.mk

diff --git a/package/libgcrypt/0001-build-Don-t-default-to-underscore-yes-for-cross-buil.patch b/package/libgcrypt/0001-build-Don-t-default-to-underscore-yes-for-cross-buil.patch
deleted file mode 100644 (file)
index 032cb7c..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From 7fec3ac22efb86fce90a9edc5696e16ee88a65c7 Mon Sep 17 00:00:00 2001
-From: NIIBE Yutaka <gniibe@fsij.org>
-Date: Wed, 24 Oct 2018 14:29:45 +0900
-Subject: [PATCH] build: Don't default to underscore=yes for cross-build.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-* acinclude.m4: Don't set ac_cv_sys_symbol_underscore
-for cross build.
-
---
-
-It made sense in the past when cross compile were basically for a.out
-system, but nowadays, it's better not to assume that.
-
-Fetched from: 0f4545b441b6fbdd6e9c4e95f5f2a367483e78ad
-
-Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
-Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
----
- acinclude.m4 | 8 ++------
- 1 file changed, 2 insertions(+), 6 deletions(-)
-
-diff --git a/acinclude.m4 b/acinclude.m4
-index fc208c53..6f7789d0 100644
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -111,14 +111,10 @@ case "${host}" in
-         ac_cv_sys_symbol_underscore=yes
-         ;;
-     *)
--      if test "$cross_compiling" = yes; then
--        if test "x$ac_cv_sys_symbol_underscore" = x ; then
--           ac_cv_sys_symbol_underscore=yes
--        fi
--      else
-+      if test "$cross_compiling" != yes; then
-          tmp_do_check="yes"
-       fi
--       ;;
-+      ;;
- esac
- if test "$tmp_do_check" = "yes"; then
-   AC_REQUIRE([AC_LIBTOOL_SYS_GLOBAL_SYMBOL_PIPE])
--- 
-2.22.0
-
diff --git a/package/libgcrypt/0001-configure.ac-add-an-option-to-disable-tests.patch b/package/libgcrypt/0001-configure.ac-add-an-option-to-disable-tests.patch
new file mode 100644 (file)
index 0000000..21ff20a
--- /dev/null
@@ -0,0 +1,66 @@
+From 7fe1b8a53cc8c865c2a10dcd8f6cb4e51ccc6300 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Mon, 29 Jul 2019 12:19:10 +0200
+Subject: [PATCH] configure.ac: add an option to disable tests
+
+Add an option to allow the user to disable tests, this can be useful for
+example when the toolchain does not provide thread. Indeed, in this
+case, libgcrypt fails to build t-lock:
+
+t-lock.c: In function 'run_test':
+t-lock.c:359:3: error: unknown type name 'pthread_t'
+   pthread_t rthread;
+
+Fixes:
+ - http://autobuild.buildroot.org/results/50a8ba572e3fafd3c6a39bd54bcfcaf78b5ad325
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ Makefile.am  |  7 ++++++-
+ configure.ac | 10 ++++++++++
+ 2 files changed, 16 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 7fa4fa4d..f0bd90e4 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -39,9 +39,14 @@ else
+ doc =
+ endif
++if BUILD_TESTS
++tests = tests
++else
++tests =
++endif
+ DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
+-SUBDIRS =         compat mpi cipher random src $(doc) tests
++SUBDIRS =         compat mpi cipher random src $(doc) $(tests)
+ EXTRA_DIST = autogen.sh autogen.rc README.GIT LICENSES                   \
+              ChangeLog-2011 build-aux/ChangeLog-2011 doc/ChangeLog-2011    \
+diff --git a/configure.ac b/configure.ac
+index e8c8cd39..1a6b61e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2710,6 +2710,16 @@ AC_ARG_ENABLE([doc], AC_HELP_STRING([--disable-doc],
+ AM_CONDITIONAL([BUILD_DOC], [test "x$build_doc" != xno])
++#
++# Option to disable building of tests
++#
++build_tests=yes
++AC_ARG_ENABLE([tests], AC_HELP_STRING([--disable-tests],
++                                      [do not build tests]),
++                       build_tests=$enableval, build_tests=yes)
++AM_CONDITIONAL([BUILD_TESTS], [test "x$build_tests" != xno])
++
++
+ #
+ # Provide information about the build.
+ #
+-- 
+2.20.1
+
diff --git a/package/libgcrypt/0002-configure.ac-add-an-option-to-disable-tests.patch b/package/libgcrypt/0002-configure.ac-add-an-option-to-disable-tests.patch
deleted file mode 100644 (file)
index 21ff20a..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-From 7fe1b8a53cc8c865c2a10dcd8f6cb4e51ccc6300 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Mon, 29 Jul 2019 12:19:10 +0200
-Subject: [PATCH] configure.ac: add an option to disable tests
-
-Add an option to allow the user to disable tests, this can be useful for
-example when the toolchain does not provide thread. Indeed, in this
-case, libgcrypt fails to build t-lock:
-
-t-lock.c: In function 'run_test':
-t-lock.c:359:3: error: unknown type name 'pthread_t'
-   pthread_t rthread;
-
-Fixes:
- - http://autobuild.buildroot.org/results/50a8ba572e3fafd3c6a39bd54bcfcaf78b5ad325
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- Makefile.am  |  7 ++++++-
- configure.ac | 10 ++++++++++
- 2 files changed, 16 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 7fa4fa4d..f0bd90e4 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -39,9 +39,14 @@ else
- doc =
- endif
-+if BUILD_TESTS
-+tests = tests
-+else
-+tests =
-+endif
- DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
--SUBDIRS =         compat mpi cipher random src $(doc) tests
-+SUBDIRS =         compat mpi cipher random src $(doc) $(tests)
- EXTRA_DIST = autogen.sh autogen.rc README.GIT LICENSES                   \
-              ChangeLog-2011 build-aux/ChangeLog-2011 doc/ChangeLog-2011    \
-diff --git a/configure.ac b/configure.ac
-index e8c8cd39..1a6b61e5 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2710,6 +2710,16 @@ AC_ARG_ENABLE([doc], AC_HELP_STRING([--disable-doc],
- AM_CONDITIONAL([BUILD_DOC], [test "x$build_doc" != xno])
-+#
-+# Option to disable building of tests
-+#
-+build_tests=yes
-+AC_ARG_ENABLE([tests], AC_HELP_STRING([--disable-tests],
-+                                      [do not build tests]),
-+                       build_tests=$enableval, build_tests=yes)
-+AM_CONDITIONAL([BUILD_TESTS], [test "x$build_tests" != xno])
-+
-+
- #
- # Provide information about the build.
- #
--- 
-2.20.1
-
index fd9169ca8bf084aee441b771111b70959f3b9a17..55d6c29695edc9d15b7078ba7cb0eafc0e75a897 100644 (file)
@@ -1,7 +1,7 @@
 # From https://www.gnupg.org/download/integrity_check.html
-sha1  ea79a279b27bf25cb1564f96693128f8fc9f41d6  libgcrypt-1.8.7.tar.bz2
+sha1  459383a8b6200673cfc31f7b265c4961c0850031  libgcrypt-1.9.0.tar.bz2
 # Locally calculated after checking signature
-# https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-1.8.7.tar.bz2.sig
+# https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-1.9.0.tar.bz2.sig
 # using key D8692123C4065DEA5E0F3AB5249B39D24F25E3B6
-sha256  03b70f028299561b7034b8966d7dd77ef16ed139c43440925fe8782561974748  libgcrypt-1.8.7.tar.bz2
+sha256  4d9ccaa5f99db59ebcb64d73f62825b05ce8a6b7f86d19178559ef84de1381cb  libgcrypt-1.9.0.tar.bz2
 sha256  ca0061fc1381a3ab242310e4b3f56389f28e3d460eb2fd822ed7a21c6f030532  COPYING.LIB
index 170c4946b0295c03bae8ca66e2a9798da9349368..a2dcdb5fee033005b1243c3b41d7c01a09c40fd5 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBGCRYPT_VERSION = 1.8.7
+LIBGCRYPT_VERSION = 1.9.0
 LIBGCRYPT_SOURCE = libgcrypt-$(LIBGCRYPT_VERSION).tar.bz2
 LIBGCRYPT_LICENSE = LGPL-2.1+
 LIBGCRYPT_LICENSE_FILES = COPYING.LIB
@@ -14,8 +14,7 @@ LIBGCRYPT_DEPENDENCIES = libgpg-error
 LIBGCRYPT_CONFIG_SCRIPTS = libgcrypt-config
 LIBGCRYPT_CPE_ID_VENDOR = gnupg
 
-# Patching acinclude.m4 in 0001
-# Patching configure.ac and Makefile.am in 0002
+# Patching configure.ac and Makefile.am in 0001
 LIBGCRYPT_AUTORECONF = YES
 LIBGCRYPT_CONF_OPTS = \
        --disable-tests \