package/dnsmasq: Fix link error with gettext
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 31 Jul 2014 19:49:20 +0000 (21:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 31 Jul 2014 21:22:10 +0000 (23:22 +0200)
-lintl needs to be added at the end of the link command, Makefile
has variable LIBS for this purpose, so use it instead of LDFLAGS.

Fixes
http://autobuild.buildroot.net/results/276/276581f6dbbe330799c3a7eaa26b453e38a22907/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dnsmasq/dnsmasq.mk

index 71d2f3029000cba7c84eec97eb3d42c9fd4dde65..6e97c68fcc6c3ddda40453253ae73cb6ba9b3b2f 100644 (file)
@@ -37,7 +37,7 @@ endif
 # NLS requires IDN so only enable it (i18n) when IDN is true
 ifeq ($(BR2_PACKAGE_DNSMASQ_IDN),y)
        DNSMASQ_DEPENDENCIES += libidn $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-gettext
-       DNSMASQ_MAKE_OPT += LDFLAGS+="-lidn $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)"
+       DNSMASQ_MAKE_OPT += LIBS+="$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)"
        DNSMASQ_COPTS += -DHAVE_IDN
        DNSMASQ_I18N = $(if $(BR2_ENABLE_LOCALE),-i18n)
 endif
@@ -58,7 +58,7 @@ ifeq ($(BR2_PACKAGE_DNSMASQ_LUA),y)
 
 # liblua uses dlopen when dynamically linked
 ifneq ($(BR2_PREFER_STATIC_LIB),y)
-       DNSMASQ_MAKE_OPT += LIBS="-ldl"
+       DNSMASQ_MAKE_OPT += LIBS+="-ldl"
 endif
 
 define DNSMASQ_ENABLE_LUA