cairo: do not depend on xserver-xorg_server, but on the right library
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Jan 2013 11:29:25 +0000 (11:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 12 Jan 2013 21:39:37 +0000 (22:39 +0100)
cairo is a X client library, so there is no reason for it to build
depend on the X.org server. What Cairo needs is the xlib_libX11
library.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cairo/Config.in
package/cairo/cairo.mk

index 398e47fb6c060f96790f0f6683be88e5fa1d52cd..4a2078eb31ea2da37bc7de71f4801205e1611399 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_CAIRO
        bool "cairo"
        select BR2_PACKAGE_PIXMAN
        select BR2_PACKAGE_FONTCONFIG
+       select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
        help
          Cairo is a 2D graphics library with support for multiple
          output devices. Currently supported output targets include
index 59a032a32662af4e8c41f89951c587a0b3dce5b3..41e876a4a0a7732a53d9af0f265f4d4fe1a3fce1 100644 (file)
@@ -49,7 +49,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
        CAIRO_CONF_OPT += --enable-xlib --with-x
-       CAIRO_DEPENDENCIES += xserver_xorg-server
+       CAIRO_DEPENDENCIES += xlib_libX11
 else
        CAIRO_CONF_OPT += --disable-xlib --without-x
 endif