usb_modeswitch: update config.guess / config.sub
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 6 Nov 2017 14:17:10 +0000 (15:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Nov 2017 12:34:39 +0000 (13:34 +0100)
Fixes:
http://autobuild.buildroot.net/results/fbe/fbe21bd173e6566dd93dddd58d4a848de8a3465e/

The build system of the embedded jimtcl copy doesn't use autotools, but does
use an old version of gnuconfig which doesn't know all the architectures
supported by Buildroot, so update config.guess / config.sub like we do in
pkg-autotools.mk

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/usb_modeswitch/usb_modeswitch.mk

index ea08de256b5ba764ebbeadef112a85954015d118..c67d4cd58312dab7f86ba69cfd87538aec50f8f0 100644 (file)
@@ -20,6 +20,12 @@ USB_MODESWITCH_BUILD_TARGETS = script
 USB_MODESWITCH_INSTALL_TARGETS = install-script
 endif
 
+# build system of embedded jimtcl doesn't use autotools, but does use
+# an old version of gnuconfig which doesn't know all the architectures
+# supported by Buildroot, so update config.guess / config.sub like we
+# do in pkg-autotools.mk
+USB_MODESWITCH_POST_PATCH_HOOKS += UPDATE_CONFIG_HOOK
+
 define USB_MODESWITCH_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -Wall -I." \