fs/erofs: add big pcluster support
authorGao Xiang <hsiangkao@aol.com>
Wed, 14 Jul 2021 14:55:28 +0000 (22:55 +0800)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 19 Jul 2021 20:34:21 +0000 (22:34 +0200)
This enables EROFS big pcluster images for buildroot.

Signed-off-by: Gao Xiang <hsiangkao@aol.com>
[yann.morin.1998@free.fr: must be a multiple of 4KiB]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
fs/erofs/Config.in
fs/erofs/erofs.mk

index d7360edeabfded1b5df4735cf47d79d21c1895c8..e1125726888e039e142a68d28ad185d49bfadda7 100644 (file)
@@ -11,4 +11,14 @@ config BR2_TARGET_ROOTFS_EROFS_LZ4HC
        help
          Use lz4 high-compression to compress data in the filesystem.
 
+config BR2_TARGET_ROOTFS_EROFS_PCLUSTERSIZE
+       int "pcluster size"
+       default 0
+       help
+         Specify the maximum size of physical cluster in bytes, as a
+         multiple of 4KiB, for the big pcluster feature in order to
+         get much better compression ratios (thus better sequential
+         read performance for common storage devices), which has been
+         introduced since Linux 5.13.
+
 endif # BR2_TARGET_ROOTFS_EROFS
index 58559d4833408bd4a407f79c51d87e1385a8a30e..0e9d4401a93950c6907637609548e5e99255888b 100644 (file)
@@ -10,6 +10,10 @@ ifeq ($(BR2_TARGET_ROOTFS_EROFS_LZ4HC),y)
 ROOTFS_EROFS_ARGS += -zlz4hc
 endif
 
+ifneq ($(BR2_TARGET_ROOTFS_EROFS_PCLUSTERSIZE),0)
+ROOTFS_EROFS_ARGS += -C$(strip $(BR2_TARGET_ROOTFS_EROFS_PCLUSTERSIZE))
+endif
+
 define ROOTFS_EROFS_CMD
        $(HOST_DIR)/bin/mkfs.erofs $(ROOTFS_EROFS_ARGS) $@ $(TARGET_DIR)
 endef