rtl8189fs: new package
authorSergey Matyukevich <geomatsi@gmail.com>
Wed, 8 Nov 2017 19:43:33 +0000 (22:43 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Dec 2017 22:27:05 +0000 (23:27 +0100)
This package adds the rtl8189fs WiFi driver. The driver is sourced
from jwrdegoede's and icenowy's work on GitHub:
   repo: https://github.com/jwrdegoede/rtl8189ES_linux.git
   branch: rtl8189fs

Driver is known to support Realtek RTL8189FTV chip.

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/rtl8189fs/Config.in [new file with mode: 0644]
package/rtl8189fs/rtl8189fs.hash [new file with mode: 0644]
package/rtl8189fs/rtl8189fs.mk [new file with mode: 0644]

index ce320221b0230ee997f9360608f58a4d2366c7b5..f96b1d07a982e13cf20e1c018653a8ebfbb8a6c6 100644 (file)
@@ -1517,6 +1517,7 @@ F:        configs/orangepi_one_defconfig
 F:     configs/orangepi_pc_plus_defconfig
 F:     configs/orangepi_zero_defconfig
 F:     package/armbian-firmware/
+F:     package/rtl8189fs/
 F:     package/xr819-xradio/
 
 N:     Sergio Prado <sergio.prado@e-labworks.com>
index aa111e48e6fb85f0eca3fed9fdb942d58a6c8040..433224c3a4c7c55fc8851c1d8604b919d95567c7 100644 (file)
@@ -486,6 +486,7 @@ endmenu
        source "package/rtl8723bs/Config.in"
        source "package/rtl8723bu/Config.in"
        source "package/rtl8821au/Config.in"
+       source "package/rtl8189fs/Config.in"
        source "package/sane-backends/Config.in"
        source "package/sdparm/Config.in"
        source "package/setserial/Config.in"
diff --git a/package/rtl8189fs/Config.in b/package/rtl8189fs/Config.in
new file mode 100644 (file)
index 0000000..ae69b79
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_RTL8189FS
+       bool "rtl8189fs"
+       depends on BR2_LINUX_KERNEL
+       help
+         Wireless driver rtl8189fs.
+
+         https://github.com/jwrdegoede/rtl8189ES_linux.git
+
+comment "rtl8189fs needs a Linux kernel to be built"
+       depends on !BR2_LINUX_KERNEL
diff --git a/package/rtl8189fs/rtl8189fs.hash b/package/rtl8189fs/rtl8189fs.hash
new file mode 100644 (file)
index 0000000..aa844cd
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 50ca09d97b22001184231b746d7133e500d3e3998a23a8ea5c3b4da72c4f72c0 rtl8189fs-04b44d437b20f28ba83fcaecc0bdab7f7647fd11.tar.gz
diff --git a/package/rtl8189fs/rtl8189fs.mk b/package/rtl8189fs/rtl8189fs.mk
new file mode 100644 (file)
index 0000000..d7add51
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# rtl8189fs
+#
+################################################################################
+
+RTL8189FS_VERSION = 04b44d437b20f28ba83fcaecc0bdab7f7647fd11
+RTL8189FS_SITE = $(call github,jwrdegoede,rtl8189ES_linux,$(RTL8189FS_VERSION))
+RTL8189FS_LICENSE = GPL-2.0
+
+RTL8189FS_MODULE_MAKE_OPTS = \
+       CONFIG_RTL8189FS=m \
+       KVER=$(LINUX_VERSION_PROBED) \
+       KSRC=$(LINUX_DIR)
+
+$(eval $(kernel-module))
+$(eval $(generic-package))