runc: pass -extldflags '-static' on when BR2_STATIC_LIBS=y
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Jul 2016 14:43:47 +0000 (16:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Jul 2016 19:59:25 +0000 (21:59 +0200)
There is no reason to link Go binaries statically, unless when
BR2_STATIC_LIBS=y.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/runc/runc.mk

index 1396e0c7a2834ef3905499a9458b7a9c43e4e446..7ebba5702b747a98fa061c01d7948019eb318150 100644 (file)
@@ -19,8 +19,11 @@ RUNC_MAKE_ENV = $(HOST_GO_TARGET_ENV) \
        PATH=$(BR_PATH)
 
 RUNC_GLDFLAGS = \
-       -X main.gitCommit=$(RUNC_VERSION) \
-       -extldflags '-static'
+       -X main.gitCommit=$(RUNC_VERSION)
+
+ifeq ($(BR2_STATIC_LIBS),y)
+FLANNEL_GLDFLAGS += -extldflags '-static'
+endif
 
 RUNC_GOTAGS = cgo static_build