Ensure DESTDIR will not confuse the build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Jul 2012 04:21:14 +0000 (04:21 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 2 Jul 2012 18:22:50 +0000 (20:22 +0200)
Having DESTDIR defined will confuse the build of certain packages, so
we ensure that it is undefined from the environment when Buildroot
starts.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index bcbe9fc10c2adbdf1003486345d9a63fb2902df6..b80477f7fc04525d6c6d2e53b2fd9a3f6ec06f78 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -168,6 +168,10 @@ export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
 # Make sure pkg-config doesn't look outside the buildroot tree
 unexport PKG_CONFIG_PATH
 
+# Having DESTDIR set in the environment confuses the installation
+# steps of some packages.
+unexport DESTDIR
+
 # bash prints the name of the directory on 'cd <dir>' if CDPATH is
 # set, so unset it here to not cause problems. Notice that the export
 # line doesn't affect the environment of $(shell ..) calls, so