package/collectd: depend on luainterpreter for lua support
authorJames Hilliard <james.hilliard1@gmail.com>
Mon, 25 May 2020 00:48:39 +0000 (18:48 -0600)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 27 Jul 2020 20:30:59 +0000 (22:30 +0200)
Since collectd lua support is compatible with any luainterpreter
implementation we should depend on BR2_PACKAGE_HAS_LUAINTERPRETER
instead of unconditionally selecting BR2_PACKAGE_LUA.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[yann.morin.1998@free.fr: use luainterpreter as dependency]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/collectd/Config.in
package/collectd/collectd.mk

index 188be3c0fb99d0e3d3b65630779eac2d79556695..276ad1732901cb2b3fdb1946857b80dfaceed68e 100644 (file)
@@ -65,11 +65,14 @@ config BR2_PACKAGE_COLLECTD_LOGSTASH
 
 config BR2_PACKAGE_COLLECTD_LUA
        bool "lua"
-       select BR2_PACKAGE_LUA
+       depends on BR2_PACKAGE_HAS_LUAINTERPRETER
        help
          Embeds a Lua interpreter into collectd and provides an
          interface to collectd's plugin system.
 
+comment "lua support needs a Lua interpreter"
+       depends on !BR2_PACKAGE_HAS_LUAINTERPRETER
+
 config BR2_PACKAGE_COLLECTD_NOTIFY_EMAIL
        bool "notify_email"
        depends on !BR2_STATIC_LIBS # libesmtp
index 24cdad7e1b93dafd39409b3544449cdced941001..6d084dbe42e7998ebb10b6a698c9078ef6946599 100644 (file)
@@ -160,7 +160,7 @@ COLLECTD_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_COLLECTD_GRPC),grpc) \
        $(if $(BR2_PACKAGE_COLLECTD_IPTABLES),iptables) \
        $(if $(BR2_PACKAGE_COLLECTD_LOGSTASH),yajl) \
-       $(if $(BR2_PACKAGE_COLLECTD_LUA),lua) \
+       $(if $(BR2_PACKAGE_COLLECTD_LUA),luainterpreter) \
        $(if $(BR2_PACKAGE_COLLECTD_MEMCACHEC),libmemcached) \
        $(if $(BR2_PACKAGE_COLLECTD_MODBUS),libmodbus) \
        $(if $(BR2_PACKAGE_COLLECTD_MQTT),mosquitto) \