package/ofono: use external ell library
authorNicolas Serafini <nicolas.serafini@sensefly.com>
Wed, 23 Oct 2019 08:43:24 +0000 (08:43 +0000)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 24 Oct 2019 09:03:20 +0000 (11:03 +0200)
Add comments to the dependencies that also come from ell. Note that the
BR2_TOOLCHAIN_HAS_SYNC_4 is coming both from ell and from internal sync
calls, so no comment is added.

While we're at it, also order the selects and DEPENDENCIES
alphabetically.

Signed-off-by: Nicolas Serafini <nicolas.serafini@sensefly.com>
[Arnout: extend "reason" comments to Config.in; alphabetical ordering]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ofono/Config.in
package/ofono/ofono.mk

index 70daef7a1bbfc675a955b3c92c85065e56a280a9..57ee4bc53628b5f4ff99851cdb50c5985c83c44f 100644 (file)
@@ -1,12 +1,13 @@
 config BR2_PACKAGE_OFONO
        bool "ofono"
-       depends on BR2_USE_WCHAR # gettext, libglib2
+       depends on BR2_USE_WCHAR # gettext, libglib2, ell
        depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
        depends on BR2_USE_MMU # dbus, libglib2
-       depends on !BR2_STATIC_LIBS # dlopen()
+       depends on !BR2_STATIC_LIBS # dlopen(), ell
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
-       select BR2_PACKAGE_LIBCAP_NG
        select BR2_PACKAGE_DBUS
+       select BR2_PACKAGE_ELL
+       select BR2_PACKAGE_LIBCAP_NG
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_MOBILE_BROADBAND_PROVIDER_INFO
        help
index 95a6c8c599eca22e2fe7ad9b8e19ff086c8b3333..18248b50d17c01719ac12078bd816092ac76aea1 100644 (file)
@@ -12,11 +12,13 @@ OFONO_LICENSE_FILES = COPYING
 OFONO_DEPENDENCIES = \
        host-pkgconf \
        dbus \
-       libglib2 \
+       ell \
        libcap-ng \
+       libglib2 \
        mobile-broadband-provider-info
 
 OFONO_CONF_OPTS = \
+       --enable-external-ell \
        --disable-test \
        --with-dbusconfdir=/etc \
        $(if $(BR2_INIT_SYSTEMD),--with-systemdunitdir=/usr/lib/systemd/system)