package/ngircd: add optional support for gnutls
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 13 Sep 2017 12:29:56 +0000 (14:29 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 11:46:20 +0000 (13:46 +0200)
openssl and gnutls can not be enabled at the same time:
https://github.com/ngircd/ngircd/blob/master/configure.ng#L449

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ngircd/ngircd.mk

index 2ab9187c8e09a0fc9a5215051946d9120058436e..06318a9df324d105eca369c896b4b763f1cc32b0 100644 (file)
@@ -16,6 +16,12 @@ NGIRCD_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr
 NGIRCD_DEPENDENCIES += openssl
 else
 NGIRCD_CONF_OPTS += --without-openssl
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+NGIRCD_CONF_OPTS += --with-gnutls=$(STAGING_DIR)/usr
+NGIRCD_DEPENDENCIES += gnutls
+else
+NGIRCD_CONF_OPTS += --without-gnutls
+endif
 endif
 
 $(eval $(autotools-package))