menu-cache: new package
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 21 Nov 2014 15:33:08 +0000 (15:33 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 00:16:09 +0000 (02:16 +0200)
[Thomas:
  - Remove the MENU_CACHE_VERSION_MINOR variable, not needed. Noticed
    by Yann E. Morin.
  - Rewrap Config.in help text.]

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/menu-cache/Config.in [new file with mode: 0644]
package/menu-cache/menu-cache.hash [new file with mode: 0644]
package/menu-cache/menu-cache.mk [new file with mode: 0644]

index 1887c6b13490354f864a737f1b444af91b18de04..8a204b4cf58b5e7440d08e36e88efebf312dfbd5 100644 (file)
@@ -806,6 +806,7 @@ menu "Graphics"
        source "package/libva/Config.in"
        source "package/libva-intel-driver/Config.in"
        source "package/libvips/Config.in"
+       source "package/menu-cache/Config.in"
        source "package/opencv/Config.in"
        source "package/opengl/Config.in"
        source "package/openjpeg/Config.in"
diff --git a/package/menu-cache/Config.in b/package/menu-cache/Config.in
new file mode 100644 (file)
index 0000000..b75c8ec
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_MENU_CACHE
+       bool "menu-cache"
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_LIBFM_EXTRA
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       help
+         Small library from LXDE project used for application menu
+         integration
+
+         http://wiki.lxde.org/
+
+comment "menu-cache needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/menu-cache/menu-cache.hash b/package/menu-cache/menu-cache.hash
new file mode 100644 (file)
index 0000000..3b9e5c4
--- /dev/null
@@ -0,0 +1,2 @@
+# From http://blog.lxde.org/?p=1299
+sha1  e7b3854109f9826472cf9795e924acebe5e27861  menu-cache-1.0.0.tar.xz
diff --git a/package/menu-cache/menu-cache.mk b/package/menu-cache/menu-cache.mk
new file mode 100644 (file)
index 0000000..9d43864
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# menu-cache
+#
+################################################################################
+
+MENU_CACHE_VERSION_MAJOR = 1.0
+MENU_CACHE_VERSION = $(MENU_CACHE_VERSION_MAJOR).0
+MENU_CACHE_SOURCE = menu-cache-$(MENU_CACHE_VERSION).tar.xz
+MENU_CACHE_SITE = http://sourceforge.net/projects/lxde/files/menu-cache/$(MENU_CACHE_VERSION_MAJOR)
+MENU_CACHE_DEPENDENCIES = libfm-extra libglib2
+MENU_CACHE_LICENSE = LGPLv2.1
+MENU_CACHE_LICENSE_FILES = COPYING
+MENU_CACHE_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))