package/rust: build and install cargo
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Fri, 7 Feb 2020 18:08:21 +0000 (19:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 27 Jul 2020 11:30:59 +0000 (13:30 +0200)
Cargo source code is not provided anymore as a separate tarball but is
now built along with the Rust compiler. So update rust host variant to
build Cargo.

For now, all this will be overwritten again by the host-cargo package,
but this package will be removed in later commits.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Patrick Havelange <patrick.havelange@essensium.com>
Tested-by: Sam Voss <sam.voss@rockwellcollins.com>
[Arnout: merge all install commands in HOST_RUST_INSTALL_CMDS]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: David Pierret <david.pierret@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rust/rust.mk

index 25153966f2ae848e456d0a334d7790a67bcf6d7c..6bee04b3b99345535909b6ca7733e8d7fa0b541f 100644 (file)
@@ -54,11 +54,14 @@ define HOST_RUST_CONFIGURE_CMDS
                echo 'python = "$(HOST_DIR)/bin/python$(HOST_RUST_PYTHON_VERSION)"'; \
                echo 'submodules = false'; \
                echo 'vendor = true'; \
+               echo 'extended = true'; \
+               echo 'tools = ["cargo"]'; \
                echo 'compiler-docs = false'; \
                echo 'docs = false'; \
                echo 'verbose = $(HOST_RUST_VERBOSITY)'; \
                echo '[install]'; \
                echo 'prefix = "$(HOST_DIR)"'; \
+               echo 'sysconfdir = "$(HOST_DIR)/etc"'; \
                echo '[rust]'; \
                echo 'channel = "stable"'; \
                echo '[target.$(RUSTC_TARGET_NAME)]'; \