package/gst-dsp: remove package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Mon, 15 Oct 2018 16:46:42 +0000 (11:46 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Oct 2018 11:56:55 +0000 (13:56 +0200)
The suit of TI OMAP3 dsp tools/libraries are being removed as the
upstream projects are no longer active.

The gst-dsp package used the tidsp-binaries package.

Suggest using Buildroot 2018.02.x LTS if the feature is still
required.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/gstreamer/Config.in
package/gstreamer/gst-dsp/Config.in [deleted file]
package/gstreamer/gst-dsp/gst-dsp.hash [deleted file]
package/gstreamer/gst-dsp/gst-dsp.mk [deleted file]

index c862532af235a476014f097cb9856514f490e5de..acf578bae504d3a34f37cfcbbcb6eabda51d95c7 100644 (file)
@@ -145,6 +145,12 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2018.11"
 
+config BR2_PACKAGE_GST_DSP
+       bool "gst-dsp package removed"
+       select BR2_LEGACY
+       help
+         The gst-dsp package was removed.
+
 config BR2_PACKAGE_BOOTUTILS
        bool "bootutils package removed"
        select BR2_LEGACY
index c6292f4a7ef1d49f71fbaca402f001da31f48a07..e922437f22252f355925efe29520ba2090dcb3ec 100644 (file)
@@ -7,7 +7,6 @@ source "package/gstreamer/gst-plugins-good/Config.in"
 source "package/gstreamer/gst-plugins-bad/Config.in"
 source "package/gstreamer/gst-plugins-ugly/Config.in"
 source "package/gstreamer/gst-ffmpeg/Config.in"
-source "package/gstreamer/gst-dsp/Config.in"
 source "package/gstreamer/gst-fsl-plugins/Config.in"
 source "package/gstreamer/gst-omapfb/Config.in"
 source "package/gstreamer/gst-plugin-x170/Config.in"
diff --git a/package/gstreamer/gst-dsp/Config.in b/package/gstreamer/gst-dsp/Config.in
deleted file mode 100644 (file)
index 102cf69..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_GST_DSP
-       bool "gst-dsp"
-       depends on BR2_cortex_a8
-       select BR2_PACKAGE_TIDSP_BINARIES
-       help
-         GStreamer plug-in to access TI OMAP3 DSP algorithms.
-
-         http://code.google.com/p/gst-dsp/
diff --git a/package/gstreamer/gst-dsp/gst-dsp.hash b/package/gstreamer/gst-dsp/gst-dsp.hash
deleted file mode 100644 (file)
index 3bccfc1..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed:
-sha256 45437a038979916de74e78a2cc7a0b01ba3982d0848e1e483a054c9cf0ce5883  gst-dsp-v0.10.2.tar.gz
diff --git a/package/gstreamer/gst-dsp/gst-dsp.mk b/package/gstreamer/gst-dsp/gst-dsp.mk
deleted file mode 100644 (file)
index dedffb9..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-################################################################################
-#
-# gst-dsp
-#
-################################################################################
-
-GST_DSP_VERSION = v0.10.2
-GST_DSP_SITE = $(call github,felipec,gst-dsp,$(GST_DSP_VERSION))
-
-define GST_DSP_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) -e
-endef
-
-define GST_DSP_INSTALL_TARGET_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) -e DESTDIR=$(TARGET_DIR) install
-endef
-
-GST_DSP_DEPENDENCIES = gstreamer tidsp-binaries host-pkgconf
-
-$(eval $(generic-package))