package/unixodbc: drop non upstreamable patch
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 12 Oct 2020 19:41:43 +0000 (21:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 12 Oct 2020 19:46:52 +0000 (21:46 +0200)
Drop patch that is not upstreamable and replace it by using
--{dis,en}able-threads option

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/unixodbc/0001-fix-nopthread.patch [deleted file]
package/unixodbc/unixodbc.mk

diff --git a/package/unixodbc/0001-fix-nopthread.patch b/package/unixodbc/0001-fix-nopthread.patch
deleted file mode 100644 (file)
index 45933e5..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-Fix pthread detection
-
-configure.in always calls AC_CHECK_COMP_OPT(pthread) which succeeds with the
-toolchain used although it does not contain thread support:
-
-checking for mutex_lock in -lthread ... no
-checking for pthread_mutex_lock in -lpthread... no
-checking for pthread_mutex_lock in -lc... no
-checking if compiler accepts -pthread... yes
-checking for pthread_mutex_lock in -lc... no
-checking for pthread_mutex_lock in -lpthread... no
-
-This positive configure check leads to
-
-    CFLAGS="$CFLAGS -pthread"
-
-in ./configure, line 15757 which causes a compilation bug
-/home/br/br4/output/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/4.8.3/../../../../arm-buildroot-linux-uclibcgnueab
-
-using this defconfig
-http://autobuild.buildroot.net/results/e86/e86e97ff7887f1bdc6bf913498392ff50f56ea88/defconfig
-
-This patch disables the freebsd-only code path. Patching configure directly
-prevents the need for autoreconf.
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-diff -uNr unixODBC-2.3.2.org/configure unixODBC-2.3.2/configure
---- unixODBC-2.3.2.org/configure       2013-10-08 10:56:03.000000000 +0200
-+++ unixODBC-2.3.2/configure   2015-03-13 21:19:59.210429211 +0100
-@@ -15746,7 +15746,7 @@
-     fi
--    if test "x$gotthread" = "xno"; then
-+    if test "x$gotthread" = "xnot_needed_for_buildroot"; then
-       if test "x$ac_cv_c_compiler_gnu" = "xyes"; then
-                 { $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts -pthread" >&5
- $as_echo_n "checking if compiler accepts -pthread... " >&6; }
index 2c936fe9d5cd8d1775670ba1148ff45b1e4dfb78..efcd5e3d4e583e5e5c70ac3fc22051d21fe7aef9 100644 (file)
@@ -34,4 +34,10 @@ else
 UNIXODBC_CONF_OPTS += --disable-readline
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+UNIXODBC_CONF_OPTS += --enable-threads
+else
+UNIXODBC_CONF_OPTS += --disable-threads
+endif
+
 $(eval $(autotools-package))