Do not include Soekris, unless i386 arch
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Thu, 20 Mar 2008 22:07:49 +0000 (22:07 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Thu, 20 Mar 2008 22:07:49 +0000 (22:07 -0000)
target/device/Soekris/Config.in
target/device/Soekris/Makefile.in

index 6d55fad16b14f4dc7618c85be6e7cc78e49348c2..925b3e5dda09b83d0805c80fb62c0446d7156929 100644 (file)
@@ -1,6 +1,11 @@
+menuconfig BR2_TARGET_SOEKRIS
+       bool "Soekris device support"
+       depends BR2_i386
+       default n
+
+if BR2_TARGET_SOEKRIS
 config BR2_TARGET_SOEKRIS_NET4521
        bool "Soekris net4521"
-       depends BR2_i386
        default n
        select BR2_PACKAGE_LINUX
        help
@@ -17,3 +22,4 @@ config BR2_TARGET_SOEKRIS_NET4801
 comment "Package support"
        depends on BR2_TARGET_SOEKRIS_NET4521 || BR2_TARGET_SOEKRIS_NET4801
 
+endif
index dad429a28c8f931269d1dfdc2e7b90b406f5484b..ce0de96d1f984c49b6092362291a2f603b48b7bb 100644 (file)
@@ -1,4 +1,6 @@
 # Override the default uClibc configuration
+ifeq ($(strip $(BR2_TARGET_SOEKRIS)),y)
+
 ifeq ($(strip $(BR2_TARGET_SOEKRIS_NET4521)),y)
 UCLIBC_CONFIG_FILE:=target/device/Soekris/net4521/uClibc.config
 BR2_PACKAGE_BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
@@ -24,3 +26,4 @@ LINUX26_KCONFIG=$(BOARD_PATH)/linux26.config
 endif
 
 endif
+endif