libxml2: explicitly state zlib dir
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 18 Oct 2014 12:30:53 +0000 (09:30 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Oct 2014 17:26:00 +0000 (19:26 +0200)
Pass the zlib directory prefix to --with-zlib otherwise it expands into
absolute (distribution) directories leading to bad test results in
configure. Fixes:
http://autobuild.buildroot.net/results/303/303d6d165c5423944122bf430575c018479733f8/build-end.log

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libxml2/libxml2.mk

index 4e296fa61fe411b442c816ee78f5998eb312e8bb..354c17853ad6a57532bc0f34cd50337ee16d9abb 100644 (file)
@@ -25,7 +25,7 @@ HOST_LIBXML2_CONF_OPTS = --without-zlib --without-lzma --without-python
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LIBXML2_DEPENDENCIES += zlib
-LIBXML2_CONF_OPTS += --with-zlib
+LIBXML2_CONF_OPTS += --with-zlib=$(STAGING_DIR)/usr
 else
 LIBXML2_CONF_OPTS += --without-zlib
 endif