teach fontconfig to actually apply its patches
authorEric Andersen <andersen@codepoet.org>
Mon, 15 Jan 2007 21:26:43 +0000 (21:26 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 15 Jan 2007 21:26:43 +0000 (21:26 -0000)
package/fontconfig/fontconfig.mk
package/fontconfig/libdir-la.patch

index 8e3c3e843e21229825f6e61414abfde9619723c5..27f529ad61ff6080ca61546ffaf8d573982e2d67 100644 (file)
@@ -16,6 +16,8 @@ fontconfig-source: $(DL_DIR)/$(FONTCONFIG_SOURCE)
 
 $(FONTCONFIG_DIR)/.unpacked: $(DL_DIR)/$(FONTCONFIG_SOURCE)
        $(FONTCONFIG_CAT) $(DL_DIR)/$(FONTCONFIG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       toolchain/patch-kernel.sh $(FONTCONFIG_DIR) package/fontconfig/ \*.patch*
+       $(CONFIG_UPDATE) $(FONTCONFIG_DIR)
        touch $(FONTCONFIG_DIR)/.unpacked
 
 $(FONTCONFIG_DIR)/.configured: $(FONTCONFIG_DIR)/.unpacked
@@ -54,6 +56,8 @@ $(STAGING_DIR)/lib/libfontconfig.so: $(FONTCONFIG_DIR)/.compiled
 
 $(TARGET_DIR)/lib/libfontconfig.so: $(STAGING_DIR)/lib/libfontconfig.so
        cp -dpf $(STAGING_DIR)/lib/libfontconfig.so* $(TARGET_DIR)/lib/
+       mkdir -p $(TARGET_DIR)/etc/fonts
+       cp $(STAGING_DIR)/etc/fonts/fonts.conf $(TARGET_DIR)/etc/fonts/
        -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libfontconfig.so
 
 fontconfig: uclibc freetype $(TARGET_DIR)/lib/libfontconfig.so
index cc6a377eb0f07651295c7fb8c2d1c58d20fee83e..672e96d4bdafb597e789517ce13610144f5c3d2e 100644 (file)
@@ -1,5 +1,5 @@
---- fontconfig/builds/unix/ltmain.sh.orig      2006-04-20 08:27:27.000000000 -0600
-+++ fontconfig/builds/unix/ltmain.sh   2007-01-13 14:26:01.000000000 -0700
+--- fontconfig/ltmain.sh.orig  2006-04-20 08:27:27.000000000 -0600
++++ fontconfig/ltmain.sh       2007-01-13 14:26:01.000000000 -0700
 @@ -273,8 +273,9 @@
        # line option must be used.
        if test -z "$tagname"; then