package/libxmlrpc: bump to version 1.39.12
authorAlvaro G. M <alvaro.gamez@hazent.com>
Fri, 13 Jan 2017 08:48:18 +0000 (09:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Jan 2017 10:53:13 +0000 (11:53 +0100)
Also:
* remove patch "Fix non C++ build" - merged upstream
* remove patch "Fix ar, ranlib handling" - merged upstream
* renumber remaining patches

Signed-off-by: Alvaro Gamez Machado <alvaro.gamez@hazent.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libxmlrpc/0002-config.mk.in-fix-shared-libraries-build-for-uClibc.patch [new file with mode: 0644]
package/libxmlrpc/0002-fix-non-cplusplus-build.patch [deleted file]
package/libxmlrpc/0003-fix-ar-ranlib-handling.patch [new file with mode: 0644]
package/libxmlrpc/0003-non-wchar-build.patch [deleted file]
package/libxmlrpc/0005-config.mk.in-fix-shared-libraries-build-for-uClibc.patch [deleted file]
package/libxmlrpc/0006-fix-ar-ranlib-handling.patch [deleted file]
package/libxmlrpc/libxmlrpc.hash
package/libxmlrpc/libxmlrpc.mk

diff --git a/package/libxmlrpc/0002-config.mk.in-fix-shared-libraries-build-for-uClibc.patch b/package/libxmlrpc/0002-config.mk.in-fix-shared-libraries-build-for-uClibc.patch
new file mode 100644 (file)
index 0000000..5970df5
--- /dev/null
@@ -0,0 +1,27 @@
+From 5d68179a54b0a34d989722dcbe3b6eb962feb27d Mon Sep 17 00:00:00 2001
+From: Romain Naour <romain.naour@openwide.fr>
+Date: Tue, 23 Dec 2014 16:04:18 +0100
+Subject: [PATCH] config.mk.in: fix shared libraries build for uClibc
+
+Signed-off-by: Romain Naour <romain.naour@openwide.fr>
+---
+ config.mk.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/config.mk.in b/config.mk.in
+index c5d4160..45461cf 100644
+--- a/config.mk.in
++++ b/config.mk.in
+@@ -166,7 +166,8 @@ shliblefn = $(1:%=%.shlibledummy)
+ # HOST_OS is usually has a version number suffix, e.g. "aix5.3.0.0", so
+ # we compare based on prefix.
+-ifeq ($(patsubst linux-gnu%,linux-gnu,$(HOST_OS)),linux-gnu)
++# linux-uclibc is also a linux
++ifeq ($(patsubst linux-%,linux-,$(HOST_OS)),linux-)
+   # Assume linker is GNU Compiler (gcc)
+   SHARED_LIB_TYPE = unix
+   MUST_BUILD_SHLIB = Y
+-- 
+1.9.3
+
diff --git a/package/libxmlrpc/0002-fix-non-cplusplus-build.patch b/package/libxmlrpc/0002-fix-non-cplusplus-build.patch
deleted file mode 100644 (file)
index 2d5bfcc..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-Handle builds without C++
-
-libxmlrpc nicely handles the fact of being built without C++ support,
-except for two locations, fixed by this patch.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Signed-off-by: Alvaro Gamez Machado <alvaro.gamez@hazent.com>
-
-Index: b/lib/util/Makefile
-===================================================================
---- a/lib/util/Makefile
-+++ b/lib/util/Makefile
-@@ -41,11 +41,14 @@
- LIBOBJS = \
-   casprintf.o \
-   cmdline_parser.o \
--  cmdline_parser_cpp.o \
-   getoptx.o \
-   string_parser.o \
-   stripcaseeq.o \
-+ifeq ($(ENABLE_CPLUSPLUS),yes)
-+LIBOBJS += cmdline_parser_cpp.o
-+endif
-+
- .PHONY: all
- all: $(LIBOBJS)
-Index: b/lib/Makefile
-===================================================================
---- a/lib/Makefile
-+++ b/lib/Makefile
-@@ -9,7 +9,10 @@
- # Build up SUBDIRS:
- SUBDIRS = 
--SUBDIRS += util libutil libutil++
-+SUBDIRS += util libutil
-+ifeq ($(ENABLE_CPLUSPLUS),yes)
-+  SUBDIRS += libutil++
-+endif
- ifeq ($(ENABLE_ABYSS_SERVER),yes)
-   SUBDIRS += abyss
-   ifeq ($(ENABLE_CPLUSPLUS),yes)
diff --git a/package/libxmlrpc/0003-fix-ar-ranlib-handling.patch b/package/libxmlrpc/0003-fix-ar-ranlib-handling.patch
new file mode 100644 (file)
index 0000000..1e58d24
--- /dev/null
@@ -0,0 +1,28 @@
+Fix detection of AR and RANLIB
+
+The configure.in script assumes that ranlib and ar are necessarily
+prefixed by ${ac_tool_prefix}, which is the value of --host. However,
+it's not necessarily the case.
+
+So instead, use AC_CHECK_TOOL to check for AR, and AC_PROG_RANLIB to
+check for RANLIB.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/configure.in
+===================================================================
+--- a/configure.in
++++ b/configure.in
+@@ -621,10 +621,8 @@
+ BUILDDIR=$(pwd)
+ AC_SUBST(BUILDDIR)
+-AR=${ac_tool_prefix}ar
+-AC_SUBST([AR])
+-RANLIB=${ac_tool_prefix}ranlib
+-AC_SUBST([RANLIB])
++AC_CHECK_TOOL([AR], [ar])
++AC_PROG_RANLIB
+ dnl =======================================================================
+ dnl Output our results.
diff --git a/package/libxmlrpc/0003-non-wchar-build.patch b/package/libxmlrpc/0003-non-wchar-build.patch
deleted file mode 100644 (file)
index 1f04353..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Disable wide-char specific code
-
-The vast majority of the libxmlrpc code nicely handles the absence of
-wide char support, except at one location, which is fixed by this
-patch.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/src/xmlrpc_decompose.c
-===================================================================
---- a/src/xmlrpc_decompose.c
-+++ b/src/xmlrpc_decompose.c
-@@ -217,7 +217,11 @@
-         xmlrpc_strfree(*decompRootP->store.Tstring.valueP);
-         break;
-     case 'w':
-+#if HAVE_UNICODE_WCHAR
-         free((void*)*decompRootP->store.TwideString.valueP);
-+#else
-+      XMLRPC_ASSERT(false);
-+#endif
-         break;
-     case '6':
-         free((void*)*decompRootP->store.TbitString.valueP);
diff --git a/package/libxmlrpc/0005-config.mk.in-fix-shared-libraries-build-for-uClibc.patch b/package/libxmlrpc/0005-config.mk.in-fix-shared-libraries-build-for-uClibc.patch
deleted file mode 100644 (file)
index 5970df5..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From 5d68179a54b0a34d989722dcbe3b6eb962feb27d Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Tue, 23 Dec 2014 16:04:18 +0100
-Subject: [PATCH] config.mk.in: fix shared libraries build for uClibc
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
----
- config.mk.in | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/config.mk.in b/config.mk.in
-index c5d4160..45461cf 100644
---- a/config.mk.in
-+++ b/config.mk.in
-@@ -166,7 +166,8 @@ shliblefn = $(1:%=%.shlibledummy)
- # HOST_OS is usually has a version number suffix, e.g. "aix5.3.0.0", so
- # we compare based on prefix.
--ifeq ($(patsubst linux-gnu%,linux-gnu,$(HOST_OS)),linux-gnu)
-+# linux-uclibc is also a linux
-+ifeq ($(patsubst linux-%,linux-,$(HOST_OS)),linux-)
-   # Assume linker is GNU Compiler (gcc)
-   SHARED_LIB_TYPE = unix
-   MUST_BUILD_SHLIB = Y
--- 
-1.9.3
-
diff --git a/package/libxmlrpc/0006-fix-ar-ranlib-handling.patch b/package/libxmlrpc/0006-fix-ar-ranlib-handling.patch
deleted file mode 100644 (file)
index 1e58d24..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-Fix detection of AR and RANLIB
-
-The configure.in script assumes that ranlib and ar are necessarily
-prefixed by ${ac_tool_prefix}, which is the value of --host. However,
-it's not necessarily the case.
-
-So instead, use AC_CHECK_TOOL to check for AR, and AC_PROG_RANLIB to
-check for RANLIB.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/configure.in
-===================================================================
---- a/configure.in
-+++ b/configure.in
-@@ -621,10 +621,8 @@
- BUILDDIR=$(pwd)
- AC_SUBST(BUILDDIR)
--AR=${ac_tool_prefix}ar
--AC_SUBST([AR])
--RANLIB=${ac_tool_prefix}ranlib
--AC_SUBST([RANLIB])
-+AC_CHECK_TOOL([AR], [ar])
-+AC_PROG_RANLIB
- dnl =======================================================================
- dnl Output our results.
index 8ec1e14ea7341df524a3e602f888e3f79a31023f..3003622ac85e7947f9e770381050b8312b700895 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 2e56cdcdd5c5fa564bcdc7a56bca108a88f5b78b34ccc85558366efabdc8b8e8 xmlrpc-c-1.39.11.tgz
+sha256 d830f3264a832dfe09f629cc64036acfd08121692526d0fabe090f7ff881ce08 xmlrpc-c-1.39.12.tgz
index 53a587780c77f7cec5eec6d0126d33f05b73e146..738ae9a81158d38d8b08b3975b4f08a1c70226ba 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBXMLRPC_VERSION = 1.39.11
+LIBXMLRPC_VERSION = 1.39.12
 LIBXMLRPC_SOURCE = xmlrpc-c-$(LIBXMLRPC_VERSION).tgz
 LIBXMLRPC_SITE = http://downloads.sourceforge.net/project/xmlrpc-c/Xmlrpc-c%20Super%20Stable/$(LIBXMLRPC_VERSION)
 LIBXMLRPC_LICENSE = BSD-3c (xml-rpc main code and abyss web server), BSD like (lib/expat), Python 1.5.2 license (parts of xmlrpc_base64.c)