package/lftp: add optional support for expat
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 23:27:31 +0000 (00:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 11:23:25 +0000 (12:23 +0100)
When expat was compiled before, the proto-http module will use it as
optional dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/lftp/4.6.4/proto-http.so | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libcrypto.so.1.0.0]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libexpat.so.1]
[...]

The build system offers no option to en-/disable expat support:
https://github.com/lavv17/lftp/blob/lftp-4.6-stable/configure.ac#L337

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lftp/lftp.mk

index d2d58fd91d6f76e1a4beb4e022953f0881c090ae..5051f707a99290b6c6436e67c07698ab949723ef 100644 (file)
@@ -17,6 +17,10 @@ ifneq ($(BR2_STATIC_LIBS),y)
 LFTP_CONF_OPTS += --with-modules
 endif
 
+ifeq ($(BR2_PACKAGE_EXPAT)$(BR2_PACKAGE_LFTP_PROTO_HTTP),yy)
+LFTP_DEPENDENCIES += expat
+endif
+
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 LFTP_DEPENDENCIES += gnutls
 LFTP_CONF_OPTS += --with-gnutls