prosody: refactor with PROSODY_CONF_OPTS variable
authorFrancois Perrad <fperrad@gmail.com>
Wed, 18 Oct 2017 16:46:48 +0000 (18:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 09:46:26 +0000 (11:46 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: keep TARGET_CONFIGURE_OPTS in the environment.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/prosody/prosody.mk

index f7a325b46082f59cdce6aaae62903f485b60ef25..b98748e3b64956e57346b2d1e2b5e562d6115549 100644 (file)
@@ -18,16 +18,19 @@ ifeq ($(BR2_PACKAGE_LUAJIT),y)
 PROSODY_DEPENDENCIES += luajit
 endif
 
+PROSODY_CONF_OPTS = \
+       --with-lua=$(STAGING_DIR)/usr \
+       --c-compiler=$(TARGET_CC) \
+       --cflags="$(TARGET_CFLAGS)" \
+       --linker=$(TARGET_CC) \
+       --ldflags="$(TARGET_LDFLAGS) -shared" \
+       --sysconfdir=/etc/prosody \
+       --prefix=/usr
+
 define PROSODY_CONFIGURE_CMDS
        cd $(@D) && \
                $(TARGET_CONFIGURE_OPTS) \
-               ./configure --prefix=/usr \
-               --c-compiler=$(TARGET_CC) \
-               --cflags="$(TARGET_CFLAGS)" \
-               --linker=$(TARGET_CC) \
-               --ldflags="$(TARGET_LDFLAGS) -shared" \
-               --sysconfdir=/etc/prosody \
-               --with-lua=$(STAGING_DIR)/usr
+               ./configure $(PROSODY_CONF_OPTS)
 endef
 
 define PROSODY_BUILD_CMDS