android-tools: add patch to fix static linking
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 May 2016 20:10:08 +0000 (22:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 May 2016 20:10:08 +0000 (22:10 +0200)
Fixes:

  http://autobuild.buildroot.net/results/c3b95741a5f6622dc9542f9eaefe295a328e2e40/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/android-tools/0005-fix-static-link-zlib.patch [new file with mode: 0644]

diff --git a/package/android-tools/0005-fix-static-link-zlib.patch b/package/android-tools/0005-fix-static-link-zlib.patch
new file mode 100644 (file)
index 0000000..dff4df6
--- /dev/null
@@ -0,0 +1,36 @@
+Fix static linking of adb/adbd
+
+Both adb and adbd use OpenSSL, which indirectly uses zlib. Since
+adb/adbd also use zlib directly -lz is included in the linker flags,
+but not at the right position to ensure that static linking works: to
+make it possible for OpenSSL symbols to see zlib symbols, -lz must
+appear after -lcrypto.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/debian/makefiles/adb.mk
+===================================================================
+--- a/debian/makefiles/adb.mk
++++ b/debian/makefiles/adb.mk
+@@ -41,7 +41,7 @@
+ CPPFLAGS+= -I$(SRCDIR)/core/adb
+ CPPFLAGS+= -I$(SRCDIR)/core/include
+-LIBS+= -lc -lpthread -lz -lcrypto
++LIBS+= -lc -lpthread -lcrypto -lz
+ OBJS= $(SRCS:.c=.o)
+Index: b/debian/makefiles/adbd.mk
+===================================================================
+--- a/debian/makefiles/adbd.mk
++++ b/debian/makefiles/adbd.mk
+@@ -44,7 +44,7 @@
+ CPPFLAGS+= -I$(SRCDIR)/core/adbd
+ CPPFLAGS+= -I$(SRCDIR)/core/include
+-LIBS+= -lc -lpthread -lz -lcrypto -lcrypt
++LIBS+= -lc -lpthread -lcrypto -lz -lcrypt
+ OBJS= $(patsubst %, %.o, $(basename $(SRCS)))