tiff: add host variant
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 5 Apr 2016 23:31:23 +0000 (20:31 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 15 Apr 2016 18:24:05 +0000 (20:24 +0200)
Add host variant to be used by host-gdk-pixbuf to update the loaders
cache.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tiff/tiff.mk

index 266272aa13ab7db213e6e0623b1af6c99bd5815b..a53d7bb3b8f4c5f2eea3723277e33fa0da9e6b65 100644 (file)
@@ -15,6 +15,14 @@ TIFF_CONF_OPTS = \
 
 TIFF_DEPENDENCIES = host-pkgconf
 
+HOST_TIFF_CONF_OPTS = \
+       --disable-cxx \
+       --without-x \
+       --disable-zlib \
+       --disable-lzma \
+       --disable-jpeg
+HOST_TIFF_DEPENDENCIES = host-pkgconf
+
 ifneq ($(BR2_PACKAGE_TIFF_CCITT),y)
 TIFF_CONF_OPTS += --disable-ccitt
 endif
@@ -81,3 +89,4 @@ endif
 TIFF_MAKE = $(MAKE) SUBDIRS="$(TIFF_SUBDIRS)"
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))