assimp: fix m68k uclinux compile
authorWaldemar Brodkorb <wbx@openadk.org>
Sun, 31 Jul 2016 18:07:43 +0000 (20:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Aug 2016 21:03:56 +0000 (23:03 +0200)
The GCC manual suggest when getting:
relocation truncated to fit: R_68K_GOT16O foobar
to use -mxgot.

https://gcc.gnu.org/onlinedocs/gcc/M680x0-Options.html

Fixes:
http://autobuild.buildroot.net/results/63898c00929b4546279bda52148b218f847714ed/
http://autobuild.buildroot.net/results/bb7a107d1ca6e8713e6ccffe6c61c43b777fb962/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/assimp/assimp.mk

index fd556e59623d8325bd9d007840dafc4cb8e27f86..cda02dda59b0a94f958c6daef61633f693dfc99b 100644 (file)
@@ -11,6 +11,11 @@ ASSIMP_LICENSE_FILES = LICENSE
 ASSIMP_DEPENDENCIES = zlib
 ASSIMP_INSTALL_STAGING = YES
 
-ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF
+# relocation truncated to fit: R_68K_GOT16O
+ifeq ($(BR2_m68k),y)
+ASSIMP_CXXFLAGS += -mxgot
+endif
+
+ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(ASSIMP_CXXFLAGS)"
 
 $(eval $(cmake-package))