mpfr: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 1 Feb 2009 19:37:09 +0000 (19:37 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 1 Feb 2009 19:37:09 +0000 (19:37 -0000)
I know that changing something as fundamental as mpfr this close to the
release isn't really ideal, but it's listed as the minimum version
for gcc 4.3.x:

http://gcc.gnu.org/install/prerequisites.html

Bernhard's tree has been using 2.3.2 since October, so the risk is probably
not that big though.

package/mpfr/mpfr.mk

index 8d3c6ab627acf14f1edf4806d1e8a8e9b175c1c1..1299ee14816a00144ddbf230b437acbb4ec1df11 100644 (file)
@@ -3,8 +3,8 @@
 # mpfr
 #
 #############################################################
-MPFR_VERSION:=2.3.0
-MPFR_PATCH:=patches
+MPFR_VERSION:=2.3.2
+#MPFR_PATCH:=patches
 MPFR_PATCH_FILE:=mpfr-$(MPFR_VERSION).patch
 MPFR_SOURCE:=mpfr-$(MPFR_VERSION).tar.bz2
 MPFR_CAT:=$(BZCAT)
@@ -13,8 +13,7 @@ MPFR_DIR:=$(TOOL_BUILD_DIR)/mpfr-$(MPFR_VERSION)
 MPFR_TARGET_DIR:=$(BUILD_DIR)/mpfr-$(MPFR_VERSION)
 MPFR_BINARY:=libmpfr$(LIBTGTEXT)
 MPFR_HOST_BINARY:=libmpfr$(HOST_SHREXT)
-MPFR_LIBVERSION:=1.0.1
-#MPFR_SVN_CMD:=svn co svn://scm.gforge.inria.fr/svn/mpfr/branches/2.3 mpfr-2.3
+MPFR_LIBVERSION:=1.1.2
 
 # need patch
 ifneq ($(MPFR_PATCH),)