uClibc: fix uclibc-menuconfig with ccache enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Feb 2011 12:18:45 +0000 (13:18 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Feb 2011 12:18:45 +0000 (13:18 +0100)
If ccache is enabled, we need to ensure it is built for the host before
anything else.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/uClibc/uclibc.mk

index a677be7a46d577e65ccaa00ef015a57a6809290e..19256bb90580aca75bb2bd9b9ebf9b8b0dd5073f 100644 (file)
@@ -395,6 +395,13 @@ $(UCLIBC_DIR)/.config: $(UCLIBC_DIR)/.oldconfig
                oldconfig
        touch $@
 
+ifeq ($(BR2_CCACHE),y)
+# we'll need ccache for the host built before make oldconfig
+# if configured, otherwise uclibc-menuconfig will fail.
+# Use order-only dependency as host-ccache is a virtual target
+$(UCLIBC_DIR)/.config: | host-ccache
+endif
+
 $(UCLIBC_DIR)/.configured: $(LINUX_HEADERS_DIR)/.configured $(UCLIBC_DIR)/.config
        $(MAKE1) -C $(UCLIBC_DIR) \
                ARCH="$(UCLIBC_TARGET_ARCH)" \