boot/uboot: Add support for dtb.img format
authorJan Viktorin <viktorin@rehivetech.com>
Tue, 14 Jul 2015 15:14:01 +0000 (17:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 22:06:04 +0000 (00:06 +0200)
Allow to generate u-boot-dtb.img. This is the same format
as u-boot.img, however, it contains a built-in device-tree.
This file is being loaded by the U-Boot SPL.

Signed-off-by: Jan Viktorin <viktorin@rehivetech.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index fa1741c1d69c5e68b51ba110f8ce6e8b909ca426..1cdb2fae9340fd7215fb2d66e0b30ecdad34ca57 100644 (file)
@@ -106,6 +106,9 @@ config BR2_TARGET_UBOOT_FORMAT_AIS
 config BR2_TARGET_UBOOT_FORMAT_BIN
        bool "u-boot.bin"
 
+config BR2_TARGET_UBOOT_FORMAT_DTB_IMG
+       bool "u-boot-dtb.img"
+
 config BR2_TARGET_UBOOT_FORMAT_IMG
        bool "u-boot.img"
 
index 2cfff282c2664941636daf512c0d4fd0e0956ad9..805367807d5361b482917f092f845fc8486826b3 100644 (file)
@@ -45,6 +45,8 @@ else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
 UBOOT_BIN = u-boot.ldr
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
 UBOOT_BIN = u-boot-nand.bin
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMG),y)
+UBOOT_BIN = u-boot-dtb.img
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)
 UBOOT_BIN = u-boot.img
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMX),y)