fs/jffs2: remove BR2_JFFS2_TARGET_SREC option
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Jan 2011 10:16:09 +0000 (11:16 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Jan 2011 10:20:38 +0000 (11:20 +0100)
This kind of custom image conversion is better handled outside BR.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/jffs2/Config.in
fs/jffs2/jffs2.mk

index edb1f4d94e196706a5c28801465c654bbef1545c..5748fbb634e5478bc09a59a29485139ebe0a1633 100644 (file)
@@ -80,11 +80,6 @@ config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
          Do not use cleanmarkers if using NAND flash or Dataflash where
          the pagesize is not a power of 2
 
-config BR2_JFFS2_TARGET_SREC
-       bool "RootFS in SREC file format"
-       help
-         The binary data will be encoded in Motorola's S-record format
-
 config BR2_TARGET_ROOTFS_JFFS2_PAD
        bool "Pad output"
 
index fd5da0c1b6484db3d68d90ec282e50f2cc95fd84..2a69849cd538bccd520bb63ac1dc7b2e2fe59bd9 100644 (file)
@@ -46,12 +46,4 @@ define ROOTFS_JFFS2_CMD
 endef
 endif
 
-define JFFS2_GEN_SREC
-       $(TARGET_CROSS)objcopy -I binary -O srec --adjust-vma 0xa1000000 $$@ $$@.srec
-endef
-
-ifeq ($(BR2_JFFS2_TARGET_SREC),y)
-ROOTFS_JFFS2_POST_GEN_HOOKS += JFFS2_GEN_SREC
-endif
-
-$(eval $(call ROOTFS_TARGET,jffs2))
\ No newline at end of file
+$(eval $(call ROOTFS_TARGET,jffs2))