rtai: install to staging
authorAndrew Barnes <andy@outsideglobe.com>
Thu, 20 Feb 2014 16:26:07 +0000 (16:26 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Apr 2014 21:07:43 +0000 (23:07 +0200)
Building RTAI userspace applications requires having the RTAI headers
and libraries installed to the staging directory, so this patch adds
RTAI_INSTALL_STAGING = YES.

In addition, this patch fixes up the rtai-config script, but does that
manually, because the rtai-config script doesn't match the convention
that the common <pkg>_CONFIG_SCRIPTS logic is designed for. It also
specifies a special directory for the RTAI headers, so that they don't
get mixed up with kernel headers.

Finally, it updates the RTAI download address to use the new correct
location.

[Thomas: fix commit log.]

Signed-off-by: Andrew Barnes <andy@outsideglobe.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rtai/rtai.mk

index c24fa41631c82eac2a57c573cf3bcb6f4036421b..72327b0d4661909c335cce3194ef199bdb7b73e8 100644 (file)
@@ -6,11 +6,20 @@
 
 RTAI_VERSION = 3.8.1
 RTAI_SOURCE  = rtai-$(RTAI_VERSION).tar.bz2
-RTAI_SITE    = http://www.rtai.org/RTAI/
+RTAI_SITE    = https://www.rtai.org/userfiles/downloads/RTAI/
+RTAI_INSTALL_STAGING = YES
+
+# The <pkg>_CONFIG_SCRIPTS cannot apply here to the specificities of rtai-config
+define RTAI_POST_PATCH_FIXUP
+       (SED) 's%^staging=.*%staging=$(STAGING_DIR)%' $(STAGING_DIR)/usr/bin/rtai-config
+endef
+
+RTAI_POST_INSTALL_STAGING_HOOKS += RTAI_POST_PATCH_FIXUP
 
 RTAI_DEPENDENCIES = linux
 
 RTAI_CONF_OPT = \
+       --includedir=/usr/include/rtai \
        --with-linux-dir=$(LINUX_DIR)   \
        --disable-leds                  \
        --disable-rtailab               \