xserver_xorg-server: option to build KDrive input drivers
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Jan 2013 11:29:18 +0000 (11:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 8 Jan 2013 23:20:38 +0000 (00:20 +0100)
When the Kdrive variant of the X server is selected, the drivers are
directly built into the X server. The X server therefore provides
options to enable or disable certain drivers, especially input
drivers.

This patch adds options to be able to enable or disable the evdev, kbd
and mouse drivers of Kdrive.

[Peter: fix Config.in indentation as pointed out by Arnout]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 4ac0ec7e87c8db7c9ff43cd0be1bfab80d323f28..053dd81503b37a0a30e7adae4fcdfb0ea0d3fd64 100644 (file)
@@ -87,6 +87,35 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER_AIGLX
     help
         Enable/Use AIGLX extension.
 
+if BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV
+       bool "Enable KDrive/TinyX evdev input driver"
+       help
+         Enable evdev input driver in KDrive. This allows KDrive to
+         use input devices that are integrated in the Linux input
+         subsystem, i.e have a /dev/input/eventX device file. This is
+         most likely the input driver you want to use.
+
+         This driver can then be enabled by running the X server
+         using:
+
+         Xfbdev -keybd evdev,,device=/dev/input/eventX -mouse evdev,,device=/dev/input/eventY.
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_KBD
+       bool "Enable KDrive/TinyX kbd input driver"
+       help
+         Enable kbd input driver in KDrive. It uses the console
+         keyboard as input device.
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_MOUSE
+       bool "Enable KDrive/TinyX mouse input driver"
+       help
+         Enable mouse input driver in KDrive. It supports PS/2 mice
+         and serial port mice.
+
+endif
+
 comment "Optional Servers"
 
 config BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB
index 623b25d9a7855b6ac595cea1d484af06f3a2ba88..92aa4b38500ef238a8b5a3fe1a883d7052b17ed9 100644 (file)
@@ -76,7 +76,26 @@ define XSERVER_CREATE_X_SYMLINK
  ln -f -s Xfbdev $(TARGET_DIR)/usr/bin/X
 endef
 XSERVER_XORG_SERVER_POST_INSTALL_TARGET_HOOKS += XSERVER_CREATE_X_SYMLINK
+
+ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV),y)
+XSERVER_XORG_SERVER_CONF_OPT += --enable-kdrive-evdev
 else
+XSERVER_XORG_SERVER_CONF_OPT += --disable-kdrive-evdev
+endif
+
+ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_KBD),y)
+XSERVER_XORG_SERVER_CONF_OPT += --enable-kdrive-kbd
+else
+XSERVER_XORG_SERVER_CONF_OPT += --disable-kdrive-kbd
+endif
+
+ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_MOUSE),y)
+XSERVER_XORG_SERVER_CONF_OPT += --enable-kdrive-mouse
+else
+XSERVER_XORG_SERVER_CONF_OPT += --disable-kdrive-mouse
+endif
+
+else # modular
 XSERVER_XORG_SERVER_CONF_OPT += --disable-kdrive --disable-xfbdev
 endif