Makefile: remove target pkgconfig files if BR2_HAVE_DEVFILES isn't enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 1 Jul 2008 12:04:28 +0000 (12:04 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 1 Jul 2008 12:04:28 +0000 (12:04 -0000)
Makefile

index fcf69ce25506933e0b73ad2ca7469de69b3bccc8..15529f78690bdaa3df37be8f069f96ccab575f2e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -332,7 +332,7 @@ target-devfiles:
 ifeq ($(BR2_HAVE_DEVFILES),y)
        ( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
 else
-       rm -rf $(TARGET_DIR)/usr/include
+       rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig
        find $(TARGET_DIR)/usr/lib -name '*.a' -delete 
        find $(TARGET_DIR)/lib -name '*.a' -delete 
        find $(TARGET_DIR)/usr/lib -name '*.la' -delete