mongoose: bump to version 5.3
authorDavide Viti <d.viti@infosolution.it>
Mon, 12 May 2014 19:31:26 +0000 (21:31 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 26 May 2014 11:53:25 +0000 (13:53 +0200)
Mongoose has changed quite drastically in the last months.
Here is a list of changes which had to be applied:

 - Bump version from 3.7 to 5.3
 - use tarball download via github helper iso git clone
 - need largefile support
 - compilation takes place into "examples"
 - weberver source is now "server.c"
 - adapt to new command line options
 - SSL support now controlled via NS_ENABLE_SSL

[Peter: extend commit text, use CFLAGS_EXTRA, only build server]
Signed-off-by: Davide Viti <zinosat@tiscali.it>
Cc: Will Wagner <will_wagner@carallon.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mongoose/Config.in
package/mongoose/S85mongoose
package/mongoose/mongoose.mk

index 35723dea23afa9d4777ae0f5dcb84c05d8084f6b..2526112d300b2c872ecc5fbcd856256ab10f7d49 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_MONGOOSE
        bool "mongoose"
+       depends on BR2_LARGEFILE
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_MMU # fork()
        help
@@ -7,6 +8,6 @@ config BR2_PACKAGE_MONGOOSE
 
          https://github.com/valenok/mongoose
 
-comment "mongoose needs a toolchain w/ threads"
+comment "mongoose needs a toolchain w/ threads, largefile"
        depends on BR2_USE_MMU
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_LARGEFILE
index dc042d0e2eb38ac98c7fce04d9b4e9b89fd2d753..98e537fd62bc38258cf6432ea166696d1cbb9bcb 100755 (executable)
@@ -10,7 +10,7 @@ NAME=mongoose
 DESC="Mongoose HTTP server"
 
 DAEMON=`which mongoose`
-OPTIONS="-num_threads 3 -document_root /var/www -listening_ports 80"
+OPTIONS="-document_root /var/www -listening_port 80"
 
 [ -e /etc/default/mongoose ] && . /etc/default/mongoose
 
index d928dd807788f11c83f1803110580f8d1ef6a908..75a4d3f59f5ed37e1c0069f93b24eedab7240264 100644 (file)
@@ -4,10 +4,9 @@
 #
 ################################################################################
 
-MONGOOSE_VERSION = 3.7
-MONGOOSE_SOURCE = mongoose-$(MONGOOSE_VERSION).tgz
-MONGOOSE_SITE = https://mongoose.googlecode.com/files
-MONGOOSE_LICENSE = MIT
+MONGOOSE_VERSION = 5.3
+MONGOOSE_SITE = $(call github,cesanta,mongoose,$(MONGOOSE_VERSION))
+MONGOOSE_LICENSE = GPLv2
 MONGOOSE_LICENSE_FILES = LICENSE
 
 MONGOOSE_CFLAGS = $(TARGET_CFLAGS) $(TARGET_LDFLAGS)
@@ -15,18 +14,16 @@ MONGOOSE_CFLAGS = $(TARGET_CFLAGS) $(TARGET_LDFLAGS)
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 MONGOOSE_DEPENDENCIES += openssl
 # directly linked
-MONGOOSE_CFLAGS += -DNO_SSL_DL -lssl -lcrypto -lz
-else
-MONGOOSE_CFLAGS += -DNO_SSL
+MONGOOSE_CFLAGS += -DNS_ENABLE_SSL -lssl -lcrypto -lz
 endif
 
 define MONGOOSE_BUILD_CMDS
-       $(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D) \
-               linux COPT="$(MONGOOSE_CFLAGS)"
+       $(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D)/examples \
+               CFLAGS_EXTRA="$(MONGOOSE_CFLAGS)" server
 endef
 
 define MONGOOSE_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 755 $(@D)/mongoose $(TARGET_DIR)/usr/sbin/mongoose
+       $(INSTALL) -D -m 755 $(@D)/examples/server $(TARGET_DIR)/usr/sbin/mongoose
        $(INSTALL) -D -m 755 package/mongoose/S85mongoose \
                $(TARGET_DIR)/etc/init.d/S85mongoose
 endef