toolchain-external-custom: allow specifying relative path to binaries
authorCalin Crisan <ccrisan@gmail.com>
Sun, 25 Mar 2018 10:18:55 +0000 (13:18 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Apr 2018 21:04:44 +0000 (23:04 +0200)
There are cases where a downloaded toolchain doesn't have its binaries
placed directly in a "bin" subfolder (where BuildRoot currently looks
for them).

A common example is the official Raspberry Pi Toolchain
(https://github.com/raspberrypi/tools), which has its binaries in
"arm-bcm2708/arm-linux-gnueabihf/bin".

This commit introduces BR2_TOOLCHAIN_EXTERNAL_REL_BIN_PATH that defaults
to "bin" and can be changed as needed.

Signed-off-by: Calin Crisan <ccrisan@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[Thomas: rework a bit how TOOLCHAIN_EXTERNAL_REL_BIN_PATH is defined.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
toolchain/toolchain-external/pkg-toolchain-external.mk
toolchain/toolchain-external/toolchain-external-custom/Config.in.options

index 3bf9fac4121c4a356e37d3be627ed444fcd4f4f2..8b2c283654531f47d65413964e91a5d581828545 100644 (file)
@@ -77,7 +77,11 @@ ifneq ($(TOOLCHAIN_EXTERNAL_PREFIX),)
 TOOLCHAIN_EXTERNAL_BIN := $(dir $(shell which $(TOOLCHAIN_EXTERNAL_PREFIX)-gcc))
 endif
 else
-TOOLCHAIN_EXTERNAL_BIN = $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/bin
+TOOLCHAIN_EXTERNAL_REL_BIN_PATH = $(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_REL_BIN_PATH))
+ifeq ($(TOOLCHAIN_EXTERNAL_REL_BIN_PATH),)
+TOOLCHAIN_EXTERNAL_REL_BIN_PATH = bin
+endif
+TOOLCHAIN_EXTERNAL_BIN = $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/$(TOOLCHAIN_EXTERNAL_REL_BIN_PATH)
 endif
 
 # If this is a buildroot toolchain, it already has a wrapper which we want to
index 8cc9db6841301424d6035683413654bc50130f86..65d94d0adfd831f78e8739dabfa77e887cc989c3 100644 (file)
@@ -12,6 +12,15 @@ config BR2_TOOLCHAIN_EXTERNAL_URL
        help
          URL of the custom toolchain tarball to download and install.
 
+config BR2_TOOLCHAIN_EXTERNAL_REL_BIN_PATH
+       string "Toolchain relative binary path"
+       default "bin"
+       depends on BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD
+       help
+         Path to where the binaries (e.g. the compiler) can be found,
+         relative to the downloaded toolchain root directory. The
+         default is "bin" and is correct for most toolchains.
+
 config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
        string "Toolchain prefix"
        default "$(ARCH)-linux"