libfreefare: add missing openssl dependency
authorSimon Dawson <spdawson@gmail.com>
Sat, 16 Jun 2012 23:07:40 +0000 (23:07 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Jun 2012 10:19:02 +0000 (12:19 +0200)
If openssl is not selected, configuration fails for the libfreefare package
as follows.

  configure: error: Cannot find libcrypto.

This patch adds the missing dependency on openssl.

[Peter: use select instead of depends on]
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libfreefare/Config.in
package/libfreefare/libfreefare.mk

index 2e11f7e351279f96028e283d1006f5382b5d4e4c..13a8630d34bd909c4c7e42950d7724768b5c874a 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LIBFREEFARE
        bool "libfreefare"
+       select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_LIBNFC
        help
          Library for high level manipulation of MIFARE cards.
index 0499999669047937d933d714c58d20fd3de86147..16ef8fb326047c4af9811e4f894b6d5147ded274 100644 (file)
@@ -5,6 +5,6 @@
 #############################################################
 LIBFREEFARE_VERSION = 0.3.2
 LIBFREEFARE_SITE = http://nfc-tools.googlecode.com/files
-LIBFREEFARE_DEPENDENCIES = libnfc
+LIBFREEFARE_DEPENDENCIES = libnfc openssl
 
 $(eval $(call AUTOTARGETS))