package/x264: needs host-nasm instead of host-yasm
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 24 Jun 2017 07:35:14 +0000 (09:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 24 Jun 2017 10:08:07 +0000 (12:08 +0200)
Upstream switched to nasm >= 2.13
http://git.videolan.org/?p=x264.git;a=commitdiff;h=d2b5f4873e2147452a723b61b14f030b2ee760a5#patch2

Fixes
http://autobuild.buildroot.net/results/3f5/3f5759a1fd6aaa0394229cdfce278752d4a01ddc/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x264/x264.mk

index 69ec4ccea377b46d8c7c7dbe6882d9b0b838c8f6..a5a967b3f7bb923c65b7e3148c1dea1e65a028bf 100644 (file)
@@ -13,9 +13,9 @@ X264_INSTALL_STAGING = YES
 X264_CONF_OPTS = --disable-avs --disable-lavf --disable-swscale
 
 ifeq ($(BR2_i386)$(BR2_x86_64),y)
-# yasm needed for assembly files
-X264_DEPENDENCIES += host-yasm
-X264_CONF_ENV += AS="$(HOST_DIR)/usr/bin/yasm"
+# nasm needed for assembly files
+X264_DEPENDENCIES += host-nasm
+X264_CONF_ENV += AS="$(HOST_DIR)/usr/bin/nasm"
 else ifeq ($(BR2_ARM_CPU_ARMV7A)$(BR2_aarch64),y)
 # We need to pass gcc as AS, because the ARM assembly files have to be
 # preprocessed