sudo: bump version, use official upstream, don't disable auth
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 7 Jun 2011 11:03:24 +0000 (13:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 7 Jun 2011 11:08:19 +0000 (13:08 +0200)
sudo without authentication doesn't make much sense, and it has very
limited impact on binary size.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sudo/Config.in
package/sudo/sudo.mk

index a1b596bbe218b4d5789780e4aac987c64370fa7f..fc0a175ec9f4e8f6ae0ae8a4bdbfbedc87135a8a 100644 (file)
@@ -5,3 +5,5 @@ config BR2_PACKAGE_SUDO
          limited root privileges to users and log root activity.  The
          basic philosophy is to give as few privileges as possible
          but still allow people to get their work done.
+
+         http://www.sudo.ws/sudo/
index fde4b77117ce417daa2c75a04edf33ba0dc8f7dc..688df164374b40eb513b0a133bdfbb9b71d8f4fc 100644 (file)
@@ -4,9 +4,8 @@
 #
 #############################################################
 
-SUDO_VERSION = 1.7.4p6
-SUDO_SITE    = $(BR2_DEBIAN_MIRROR)/debian/pool/main/s/sudo
-SUDO_SOURCE  = sudo_$(SUDO_VERSION).orig.tar.gz
+SUDO_VERSION = 1.7.6p2
+SUDO_SITE    = http://www.sudo.ws/sudo/dist
 
 SUDO_CONF_OPT = \
                --without-lecture \
@@ -14,7 +13,6 @@ SUDO_CONF_OPT = \
                --without-umask \
                --with-logging=syslog \
                --without-interfaces \
-               --disable-authentication \
                --without-pam
 
 define SUDO_INSTALL_TARGET_CMDS