czmq: disable asciidoc documentation generation
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 12 May 2013 09:15:52 +0000 (09:15 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 May 2013 19:28:10 +0000 (21:28 +0200)
czmq uses asciidoc for its documentation. asciidoc uses python and import
the unicodedata module, which is not in host-python. So disable asciidoc
entirely.

This doesn't get hit by the autobuilders because they don't have asciidoc
installed in their chroot.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/czmq/czmq.mk

index 2b34654faa54d7ec65394432347d7514eaf477dd..d63fb7847926e302bdb82933f1d6f90ff6dbe941 100644 (file)
@@ -14,6 +14,10 @@ CZMQ_DEPENDENCIES = zeromq
 CZMQ_LICENSE = LGPLv3+ with exceptions
 CZMQ_LICENSE_FILES = COPYING COPYING.LESSER
 
+# asciidoc is a python script that imports unicodedata, which is not in
+# host-python, so disable asciidoc entirely.
+CZMQ_CONF_ENV = ac_cv_prog_czmq_have_asciidoc=no
+
 define CZMQ_CREATE_CONFIG_DIR
        mkdir -p $(@D)/config
 endef